summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:47:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:47:46 +0100
commit290fba178f2c4eb5e066ece9f27f0d1aacf83191 (patch)
tree6e54f58dbb63abf12d19f5a373d1539b4d234cac /dev-haskell/hsql
parentprofiles/package.mask: mask dev-lang/epic for removal (diff)
downloadgentoo-290fba178f2c4eb5e066ece9f27f0d1aacf83191.tar.gz
gentoo-290fba178f2c4eb5e066ece9f27f0d1aacf83191.tar.bz2
gentoo-290fba178f2c4eb5e066ece9f27f0d1aacf83191.zip
dev-haskell/hsql: tweak for ghc-8.4
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/735664 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hsql')
-rw-r--r--dev-haskell/hsql/files/hsql-1.8.2-ghc84.patch29
-rw-r--r--dev-haskell/hsql/hsql-1.8.2-r1.ebuild8
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-haskell/hsql/files/hsql-1.8.2-ghc84.patch b/dev-haskell/hsql/files/hsql-1.8.2-ghc84.patch
new file mode 100644
index 000000000000..8f90d43393e2
--- /dev/null
+++ b/dev-haskell/hsql/files/hsql-1.8.2-ghc84.patch
@@ -0,0 +1,29 @@
+--- a/DB/HSQL/Core.hs
++++ b/DB/HSQL/Core.hs
+@@ -7,3 +7,3 @@ import Control.Exception(Exception,throw,catch,handle)
+ import Control.Concurrent.MVar(MVar,withMVar,modifyMVar_)
+-import Data.Dynamic(cast)
++import Data.Typeable(cast)
+
+--- a/DB/HSQL/Error.hs
++++ b/DB/HSQL/Error.hs
+@@ -7,3 +7,3 @@ module DB.HSQL.Error(SqlError(..)) where
+ import Control.Exception(Exception(..),SomeException(..))
+-import Data.Dynamic(Typeable,TyCon,mkTyCon3,cast)
++import Data.Typeable(Typeable, cast)
+ import DB.HSQL.Type(SqlType)
+@@ -32,14 +32,3 @@ data SqlError
+ | SqlClosedHandle -- ^ referenced handle is already closed
+-#ifdef __GLASGOW_HASKELL__
+ deriving (Eq,Ord,Typeable)
+-#else
+- deriving (Eq,Ord)
+-
+-instance Typeable SqlError where
+- typeOf _ = mkAppTy sqlErrorTc []
+-#endif
+-
+--- | The `TyCon' of `SqlError'.
+-sqlErrorTc :: TyCon
+-sqlErrorTc = mkTyCon3 "DB.HSQL" "Error" "SqlError"
+
diff --git a/dev-haskell/hsql/hsql-1.8.2-r1.ebuild b/dev-haskell/hsql/hsql-1.8.2-r1.ebuild
index 5d1559a6e3a1..53a5a9d3ae0b 100644
--- a/dev-haskell/hsql/hsql-1.8.2-r1.ebuild
+++ b/dev-haskell/hsql/hsql-1.8.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
# ebuild generated by hackport 0.4.6.9999
@@ -24,8 +24,12 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
"
+PATCHES=(
+ "${FILESDIR}"/${P}-ghc84.patch
+)
+
pkg_postinst() {
- ghc-package_pkg_postinst
+ haskell-cabal_pkg_postinst
elog "You will probably want to emerge one or more HSQL backend."
elog "These backends are available:"