summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hsql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hsql')
-rw-r--r--dev-haskell/hsql/Manifest2
-rw-r--r--dev-haskell/hsql/files/hsql-1.8.1-ghc-7.4.patch13
-rw-r--r--dev-haskell/hsql/hsql-1.8.1.ebuild36
-rw-r--r--dev-haskell/hsql/hsql-1.8.2.ebuild34
-rw-r--r--dev-haskell/hsql/metadata.xml8
5 files changed, 93 insertions, 0 deletions
diff --git a/dev-haskell/hsql/Manifest b/dev-haskell/hsql/Manifest
new file mode 100644
index 000000000000..59c3bc63f0bd
--- /dev/null
+++ b/dev-haskell/hsql/Manifest
@@ -0,0 +1,2 @@
+DIST hsql-1.8.1.tar.gz 9365 SHA256 bff33ef9109a9e27333f239bb999f224192da5a1a91a78a0bf3ba1b514107dc9 SHA512 3f174a9684bb7ce78a9ba66d15be584fb312bc2fb95b67b1005a3e6fbc48816428e6ab6bbc2ada6ce1094fbd20b9f0553e70463f0e406b252fccff5c3829c475 WHIRLPOOL d33ab8266e3b000cdaf9ac5633e51d01f5d29eb7586771e4b6c91697dbb3a867d1f7ea809032bf690f22bcc040762ad298b8ffa2594c0e5a022c2056409b8416
+DIST hsql-1.8.2.tar.gz 10568 SHA256 7e2d32eb0d3a1e30ec8fe02ff41b8975298249ccf54ef2e9774260eb05b1a344 SHA512 f4a002573bead2de330d526ab4158517e66f92f4d6a87a517dd2e7949abb7566c318d96e4072535b157f3d40a5714702f4127ea106ab976bf5f0ec302e50c6f6 WHIRLPOOL 938cc447a81ad9c2aa0e254d25bf1c3aec1783de33144af53e310cce5a5fe08cb7657e847f383c9dc2f9535ac3db1784becab25115225e0473c9d9243c5cacc3
diff --git a/dev-haskell/hsql/files/hsql-1.8.1-ghc-7.4.patch b/dev-haskell/hsql/files/hsql-1.8.1-ghc-7.4.patch
new file mode 100644
index 000000000000..c8af51d865de
--- /dev/null
+++ b/dev-haskell/hsql/files/hsql-1.8.1-ghc-7.4.patch
@@ -0,0 +1,13 @@
+diff --git a/hsql.cabal b/hsql.cabal
+index 6595eee..7e198e9 100644
+--- a/hsql.cabal
++++ b/hsql.cabal
+@@ -19,7 +19,7 @@ exposed-modules:
+ Database.HSQL.Types
+ build-depends: base==4.*, old-time
+ extensions: CPP, ForeignFunctionInterface, DeriveDataTypeable, RankNTypes,
+- ScopedTypeVariables
++ ScopedTypeVariables, FlexibleInstances
+ build-type: Simple
+ license-file: LICENSE
+ cabal-version: >= 1.6
diff --git a/dev-haskell/hsql/hsql-1.8.1.ebuild b/dev-haskell/hsql/hsql-1.8.1.ebuild
new file mode 100644
index 000000000000..39d4a72beead
--- /dev/null
+++ b/dev-haskell/hsql/hsql-1.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.13
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+DESCRIPTION="Simple library for database access from Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/hsql"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-7.4.patch)
+
+pkg_postinst () {
+ ghc-package_pkg_postinst
+
+ elog "You will probably want to emerge one or more HSQL backend."
+ elog "These backends are available:"
+ elog " hsql-postgresql"
+ elog " hsql-mysql"
+ elog " hsql-sqlite"
+ elog " hsql-odbc"
+}
diff --git a/dev-haskell/hsql/hsql-1.8.2.ebuild b/dev-haskell/hsql/hsql-1.8.2.ebuild
new file mode 100644
index 000000000000..4b56cb1b1717
--- /dev/null
+++ b/dev-haskell/hsql/hsql-1.8.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.13
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit base haskell-cabal
+
+DESCRIPTION="Database access from Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/hsql"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+pkg_postinst () {
+ ghc-package_pkg_postinst
+
+ elog "You will probably want to emerge one or more HSQL backend."
+ elog "These backends are available:"
+ elog " hsql-postgresql"
+ elog " hsql-mysql"
+ elog " hsql-sqlite"
+ elog " hsql-odbc"
+}
diff --git a/dev-haskell/hsql/metadata.xml b/dev-haskell/hsql/metadata.xml
new file mode 100644
index 000000000000..cf220d8043b5
--- /dev/null
+++ b/dev-haskell/hsql/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Simple library for database access from Haskell.
+ </longdescription>
+</pkgmetadata>