summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:05:40 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:42 +0100
commit19598d4a6196f71769aa17f073361e4f43d9d016 (patch)
treeb9b63008538221e198a2ef4230b6b419ff89eccc /dev-haskell/hsyaml-aeson
parentdev-haskell/lrucache: add package (diff)
downloadgentoo-19598d4a6196f71769aa17f073361e4f43d9d016.tar.gz
gentoo-19598d4a6196f71769aa17f073361e4f43d9d016.tar.bz2
gentoo-19598d4a6196f71769aa17f073361e4f43d9d016.zip
dev-haskell/hsyaml-aeson: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hsyaml-aeson')
-rw-r--r--dev-haskell/hsyaml-aeson/Manifest1
-rw-r--r--dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild40
-rw-r--r--dev-haskell/hsyaml-aeson/metadata.xml21
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-haskell/hsyaml-aeson/Manifest b/dev-haskell/hsyaml-aeson/Manifest
new file mode 100644
index 000000000000..7b09584c0b17
--- /dev/null
+++ b/dev-haskell/hsyaml-aeson/Manifest
@@ -0,0 +1 @@
+DIST HsYAML-aeson-0.2.0.0.tar.gz 11095 BLAKE2B b168c5d676718c99567835aaaa53321ccecc7b089e15850676a0b600f6ea2280facd4cf22e0212807c6c952287b125d52974ed19240390c0bc22d54c7047a641 SHA512 09da59c38e9fead3b11bbb6752cef803ae2d60392b710ea3958091d6256ff267f0b0f9b27293bbbc96a9d3af08464e463feafcba4a7caab6fd78286127f91527
diff --git a/dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild b/dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild
new file mode 100644
index 000000000000..a6483a89c316
--- /dev/null
+++ b/dev-haskell/hsyaml-aeson/hsyaml-aeson-0.2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HsYAML-aeson"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="JSON to YAML Adapter"
+HOMEPAGE="https://github.com/hvr/HsYAML"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-1.2.3:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.5 && < 4.14' 'base >= 4.5' \
+ 'containers >=0.4.2 && <0.7' 'containers >=0.4.2'
+}
diff --git a/dev-haskell/hsyaml-aeson/metadata.xml b/dev-haskell/hsyaml-aeson/metadata.xml
new file mode 100644
index 000000000000..a66d30e2a063
--- /dev/null
+++ b/dev-haskell/hsyaml-aeson/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The [YAML 1.2](https://yaml.org/spec/1.2/spec.html) format provides
+ a much richer data-model and feature-set
+ than the [JavaScript Object Notation (JSON)](https://tools.ietf.org/html/rfc7159) format.
+ However, sometimes it's desirable to ignore the extra capabilities
+ and treat YAML as if it was merely a more convenient markup format
+ for humans to write JSON data. To this end this module provides a
+ compatibility layer atop [HsYAML](https://hackage.haskell.org/package/HsYAML)
+ which allows decoding YAML documents in the more limited JSON data-model while also providing
+ convenience by reusing [aeson](https://hackage.haskell.org/package/aeson)'s
+ 'FromJSON' instances for decoding the YAML data into native Haskell data
+ types.
+ </longdescription>
+</pkgmetadata>