summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-08-04 11:09:54 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-04 07:21:40 +0100
commit7860fc1797fcf426363dda176f376d5fede4a351 (patch)
treeb06e352dddac0075a52f20ad0b911df331a68cdf /dev-haskell/http-streams
parentdev-haskell/snap-server: bump up to 1.1.1.2 (diff)
downloadgentoo-7860fc1797fcf426363dda176f376d5fede4a351.tar.gz
gentoo-7860fc1797fcf426363dda176f376d5fede4a351.tar.bz2
gentoo-7860fc1797fcf426363dda176f376d5fede4a351.zip
dev-haskell/http-streams: bump up to 0.8.7.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/http-streams')
-rw-r--r--dev-haskell/http-streams/Manifest1
-rw-r--r--dev-haskell/http-streams/http-streams-0.8.7.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/http-streams/Manifest b/dev-haskell/http-streams/Manifest
index e13b548e8080..79a81c594237 100644
--- a/dev-haskell/http-streams/Manifest
+++ b/dev-haskell/http-streams/Manifest
@@ -1 +1,2 @@
DIST http-streams-0.8.4.0.tar.gz 35330 BLAKE2B 6e6c0fbd9a61c6ea587d7140fb0219c5a415c798ee55b47f45642c19cc67f67a6c1098d74c8451bb6285fdc001d6cac389459a3dbd5ba9409a59e47e4bf4c9a5 SHA512 763287042b37eca43941369dd2b7a7693f545ef37d87bdadb0b5ee686648bc0c3e7d2a8edee37648bb61ebc1dfefb029ca3ce22a44519a16775eab98de0b0a1a
+DIST http-streams-0.8.7.1.tar.gz 35149 BLAKE2B c7b754b694b612f167b072e17abf14a537aa36422ee4a55695c25b84e8780a6acff61ad9d2041b0ee2cc2cf51f77cdee732021870418d506cbf07a80cbb1b88e SHA512 6c2613cc6bcc1b54916c484834779fb3388085082df33216beb12685eb8e56c0f45b2bf24d657acc6c0295ea429c0e1947213a1235c4373cfdcf10899c93bee1
diff --git a/dev-haskell/http-streams/http-streams-0.8.7.1.ebuild b/dev-haskell/http-streams/http-streams-0.8.7.1.ebuild
new file mode 100644
index 000000000000..f508569b5ad7
--- /dev/null
+++ b/dev-haskell/http-streams/http-streams-0.8.7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client using io-streams"
+HOMEPAGE="https://github.com/afcowie/http-streams/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RESTRICT=test #circular test depend: http-streams -> snap-server -> http-streams
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-builder-0.4:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/hsopenssl-0.11.2:=[profile?]
+ >=dev-haskell/http-common-0.8.2:=[profile?]
+ >=dev-haskell/io-streams-1.3:=[profile?] <dev-haskell/io-streams-1.6:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/openssl-streams-1.1:=[profile?] <dev-haskell/openssl-streams-1.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?]
+ <dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24
+ test? ( dev-haskell/aeson-pretty
+ dev-haskell/hspec
+ dev-haskell/hspec-expectations
+ dev-haskell/hunit
+ dev-haskell/lifted-base
+ >=dev-haskell/snap-core-1.0 <dev-haskell/snap-core-1.2
+ >=dev-haskell/snap-server-1.1 <dev-haskell/snap-server-1.2
+ >=dev-haskell/system-fileio-0.3.10 <dev-haskell/system-fileio-0.4
+ >=dev-haskell/system-filepath-0.4.1 <dev-haskell/system-filepath-0.5
+ !network-uri? ( >=dev-haskell/network-2.6
+ >=dev-haskell/network-uri-2.6 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}