summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-15 22:28:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:28 +0000
commit7e7c426734eb5175533f9b389dd3f6d3950ded70 (patch)
treee2c39dd2cbae840bb0241c1f1da00e97ef9b2b35 /dev-haskell/http2/http2-1.6.2.ebuild
parentapp-text/pandoc: bump up to 1.18 (diff)
downloadgentoo-7e7c426734eb5175533f9b389dd3f6d3950ded70.tar.gz
gentoo-7e7c426734eb5175533f9b389dd3f6d3950ded70.tar.bz2
gentoo-7e7c426734eb5175533f9b389dd3f6d3950ded70.zip
dev-haskell/http2: bump up to 1.6.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/http2/http2-1.6.2.ebuild')
-rw-r--r--dev-haskell/http2/http2-1.6.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/http2/http2-1.6.2.ebuild b/dev-haskell/http2/http2-1.6.2.ebuild
new file mode 100644
index 000000000000..5fc5f6aff37a
--- /dev/null
+++ b/dev-haskell/http2/http2-1.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+#hackport: flags: -devel
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP/2.0 library including frames and HPACK"
+HOMEPAGE="http://hackage.haskell.org/package/http2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/bytestring-builder:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/psqueues:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( dev-haskell/aeson
+ dev-haskell/aeson-pretty
+ >=dev-haskell/doctest-0.9.3
+ dev-haskell/glob
+ dev-haskell/hex
+ >=dev-haskell/hspec-1.3
+ dev-haskell/text
+ dev-haskell/unordered-containers
+ dev-haskell/vector
+ dev-haskell/word8 )
+"
+
+src_prepare() {
+ # workaround Cabal bug at picking unused deps
+ eapply "${FILESDIR}"/${PN}-1.6.0-less-deps.patch
+ eapply "${FILESDIR}"/${PN}-1.6.0-even-less-deps.patch
+ eapply_user
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-devel
+}