summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-08-06 18:11:29 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-06 19:47:18 +0100
commit02707a500a0648128e7e3e538e4f6371037211db (patch)
tree6b118ebab4b13006093b55a47a8fa9e9219b4d77 /dev-haskell/json
parentdev-haskell/happstack-server: remove old (diff)
downloadgentoo-02707a500a0648128e7e3e538e4f6371037211db.tar.gz
gentoo-02707a500a0648128e7e3e538e4f6371037211db.tar.bz2
gentoo-02707a500a0648128e7e3e538e4f6371037211db.zip
dev-haskell/json: bump up to 0.10
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/json')
-rw-r--r--dev-haskell/json/Manifest1
-rw-r--r--dev-haskell/json/json-0.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/json/Manifest b/dev-haskell/json/Manifest
index 99269fc1f1d7..85c9ae0ab274 100644
--- a/dev-haskell/json/Manifest
+++ b/dev-haskell/json/Manifest
@@ -1,2 +1,3 @@
+DIST json-0.10.tar.gz 22622 BLAKE2B 4ee854a80738b6d12e027ca8562ac365bc6192532682d9b8997a8887b70d2e19553535fec6c7ab6ecf119262d6f7d229dc4217ac867dcac8dd3158c80606c727 SHA512 4015693c363810701114a222207083ab9610ebd1196d24f0eb8dcad35af54e9067259ca412b131eaa986b8dbfbf0ce62058ca4c31aeeff29fdf21f17e8d86e90
DIST json-0.9.1.tar.gz 22568 BLAKE2B b1c73771e24ccafb2019ffff61e392f2eec18768c4bdd09f1a5ee8275c92d8982cda3fab4d91222f726fae65324776c9e79ccd602dbd4ac9c435749d61a1015e SHA512 537257fed476683d0657c6474e465ca437e43e36b60ab132c0f584cece99a18d222ef9a33171543689ba5589434bc78cf2e0e5ff550804ff8969052d09430d57
DIST json-0.9.3.tar.gz 22562 BLAKE2B 8947d2b4bea1ee86eea19e25b73b991d186274c7a6beaff09e8f346756e870d440c4511c599d6ee5f82df08975076e47f0f528cc03cabb5063fb768506b9a660 SHA512 836ae920ef19e0cff5b617a579090ea1d760e253513d3fb28c56650a1fa413c0bd852165be487c211a52be6246eac3241a97f729342223be10275917a34230a6
diff --git a/dev-haskell/json/json-0.10.ebuild b/dev-haskell/json/json-0.10.ebuild
new file mode 100644
index 000000000000..55a5773eba27
--- /dev/null
+++ b/dev-haskell/json/json-0.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Support for serialising Haskell to and from JSON"
+HOMEPAGE="https://hackage.haskell.org/package/json"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="mapdict +parsec +pretty"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/syb-0.3.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ parsec? ( dev-haskell/parsec:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag mapdict mapdict) \
+ $(cabal_flag parsec parsec) \
+ $(cabal_flag pretty pretty)
+}