summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/language-c
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/language-c')
-rw-r--r--dev-haskell/language-c/Manifest3
-rw-r--r--dev-haskell/language-c/language-c-0.4.2.ebuild30
-rw-r--r--dev-haskell/language-c/language-c-0.4.5.ebuild36
-rw-r--r--dev-haskell/language-c/language-c-0.4.7.ebuild36
-rw-r--r--dev-haskell/language-c/metadata.xml8
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-haskell/language-c/Manifest b/dev-haskell/language-c/Manifest
new file mode 100644
index 000000000000..b9e3a7ac7c01
--- /dev/null
+++ b/dev-haskell/language-c/Manifest
@@ -0,0 +1,3 @@
+DIST language-c-0.4.2.tar.gz 167052 SHA256 6384cf03a00008b65ad126c2582699b3de52de594468386d2c79cf63c926ee1e SHA512 e2cd4c2871c04fecdcdf82026c79edf7681e00bf632fcff6c119cbd95e53905695bd8f08010d2662e10d883b2fdf6bb114a199b0eaf7be31ff65aaa29df6083b WHIRLPOOL 82d3ccfc44788eda9330bf7493deb06b9e2f02bd0ccd445cc74799e1e87e666530e44d63898d0b492be125dd03504acdebd384e18234e9fd21075fe9a522a0cc
+DIST language-c-0.4.5.tar.gz 168971 SHA256 644a7f6657f0325149f16c755ba3e51353f0d18484282989cf473c726a0e1d60 SHA512 2e6fd98ed34c805e4b713ccf380db5e8871f868afb11d1337769137ed2861120c26e9a3be026c6c3b57e6f27ec88d6296e31208ec074c1f37ed08fa4d466e2e2 WHIRLPOOL 2941b6fdd7bf0b75973847d7af5f69036050ef345dcd649c017384164596d48bd30e4bf9c52734f91f2ee28776c834d0358e4bea64ce5744cece2c6c237bcdce
+DIST language-c-0.4.7.tar.gz 112569 SHA256 5f6dc9d86b1f88dec1800e1a4fc43aa52f85fe4bb865ba268aca34b399a512e4 SHA512 fb2602606b8c2e678e170d928c3dd023acccc079381a37b64624af658788c0dee982c2d53c2d3ba66b576aa75de350d12e35a94f867e1d714e89c27d26f2af6b WHIRLPOOL a3f790ac48af034f99b4892e1e7114b4e9a7d2ab010a20efaf890fc5345c3e326bd9afabf7c678196cbd03658f243954c13edfa7aaf4a11b2c887be0e10e9bbf
diff --git a/dev-haskell/language-c/language-c-0.4.2.ebuild b/dev-haskell/language-c/language-c-0.4.2.ebuild
new file mode 100644
index 000000000000..bb31503089e4
--- /dev/null
+++ b/dev-haskell/language-c/language-c-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Analysis and generation of C code"
+HOMEPAGE="http://www.sivity.net/projects/language.c/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/syb[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.6
+ dev-haskell/happy"
+
+src_prepare() {
+ rm -vf "${S}"/dist/build/Language/C/Parser/{Lexer,Parser}.hs
+}
diff --git a/dev-haskell/language-c/language-c-0.4.5.ebuild b/dev-haskell/language-c/language-c-0.4.5.ebuild
new file mode 100644
index 000000000000..9644f04791ea
--- /dev/null
+++ b/dev-haskell/language-c/language-c-0.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+#hackport: flags: +separatesyb,+usebytestrings,+splitbase
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Analysis and generation of C code"
+HOMEPAGE="http://www.sivity.net/projects/language.c/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/syb:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.6
+ dev-haskell/happy
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=separatesyb \
+ --flag=splitbase \
+ --flag=usebytestrings
+}
diff --git a/dev-haskell/language-c/language-c-0.4.7.ebuild b/dev-haskell/language-c/language-c-0.4.7.ebuild
new file mode 100644
index 000000000000..ce4e4cc30478
--- /dev/null
+++ b/dev-haskell/language-c/language-c-0.4.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: +separatesyb,+usebytestrings,+splitbase
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Analysis and generation of C code"
+HOMEPAGE="http://www.sivity.net/projects/language.c/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/syb:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.6
+ dev-haskell/happy
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=separatesyb \
+ --flag=splitbase \
+ --flag=usebytestrings
+}
diff --git a/dev-haskell/language-c/metadata.xml b/dev-haskell/language-c/metadata.xml
new file mode 100644
index 000000000000..8c66906af531
--- /dev/null
+++ b/dev-haskell/language-c/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>