summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-24 10:39:35 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-24 10:41:12 +0100
commit7f251e6cb6f81600e81264861e7479e5e0b9836e (patch)
tree390980eafc2cafef80306fc5c4c073bfe5f76ae5 /dev-haskell/lcs
parentdev-haskell/language-c: update to EAPI=7 (diff)
downloadgentoo-7f251e6cb6f81600e81264861e7479e5e0b9836e.tar.gz
gentoo-7f251e6cb6f81600e81264861e7479e5e0b9836e.tar.bz2
gentoo-7f251e6cb6f81600e81264861e7479e5e0b9836e.zip
dev-haskell/lcs: update to EAPI=7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/lcs')
-rw-r--r--dev-haskell/lcs/lcs-0.2-r1.ebuild12
-rw-r--r--dev-haskell/lcs/metadata.xml19
2 files changed, 5 insertions, 26 deletions
diff --git a/dev-haskell/lcs/lcs-0.2-r1.ebuild b/dev-haskell/lcs/lcs-0.2-r1.ebuild
index 7fbefa014669..245d4794375c 100644
--- a/dev-haskell/lcs/lcs-0.2-r1.ebuild
+++ b/dev-haskell/lcs/lcs-0.2-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.4.5.9999
+# ebuild generated by hackport 0.6.6.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit eutils haskell-cabal
+inherit haskell-cabal
DESCRIPTION="Find longest common sublist of two lists"
HOMEPAGE="http://urchin.earth.li/~ian/cabal/lcs/"
@@ -20,9 +20,7 @@ IUSE=""
RDEPEND=">=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
- dev-haskell/cabal
+ >=dev-haskell/cabal-1.0
"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ghc-7.10.patch
-}
+PATCHES=("${FILESDIR}"/${P}-ghc-7.10.patch)
diff --git a/dev-haskell/lcs/metadata.xml b/dev-haskell/lcs/metadata.xml
index 7a626927e1e6..b7878815d80d 100644
--- a/dev-haskell/lcs/metadata.xml
+++ b/dev-haskell/lcs/metadata.xml
@@ -5,23 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Provides a function lcs that takes two lists and returns a longest
- common sublist. For example, lcs "abcd" "acbd" is either "abd" or
- "acd".
-
- The package provides a simple, stupid and (most of all) slow
- implementation that needs, for inputs of length m and n, O(m+n)
- space and O((m+n)!) time in the worst case.
-
- It also provides an implementation of the Hunt-Szymanski LCS
- algorithm, based on that in "String searching algorithms" by
- Graham A Stephen, ISBN 981021829X.
-
- Given inputs xs and ys of length m and n respectively, where there
- are r pairs (x, y) where x is in xs, y is in ys and x == y,
- Hunt-Szymanski needs O(r+m+n) space and O((r+m+n)*log(m+n)) time.
- Thus this is O((m+n)^2) space and O((m+n)^2*log(m+n)) time in the
- worst case.
- </longdescription>
</pkgmetadata>