summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:48:53 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:12 +0100
commitceacf612785ee252fd5ace43efb02378c9f3939b (patch)
tree9938436b5fd6dbdf3af3081ac9faa4fa860e2224 /dev-haskell/parsers
parentdev-haskell/charset: add package (diff)
downloadgentoo-ceacf612785ee252fd5ace43efb02378c9f3939b.tar.gz
gentoo-ceacf612785ee252fd5ace43efb02378c9f3939b.tar.bz2
gentoo-ceacf612785ee252fd5ace43efb02378c9f3939b.zip
dev-haskell/parsers: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/parsers')
-rw-r--r--dev-haskell/parsers/Manifest1
-rw-r--r--dev-haskell/parsers/metadata.xml19
-rw-r--r--dev-haskell/parsers/parsers-0.12.10.ebuild41
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/parsers/Manifest b/dev-haskell/parsers/Manifest
new file mode 100644
index 000000000000..be0190f33d01
--- /dev/null
+++ b/dev-haskell/parsers/Manifest
@@ -0,0 +1 @@
+DIST parsers-0.12.10.tar.gz 26215 BLAKE2B 35303f6f4919e07b77490f5bcbc2a45efe8fda5edf169ade7dd7cd3bd080f2d24d5470ecb47f8a6428be1176faa8d138616e8f2635f9974ed473c8a61145e8ee SHA512 99ff90de4e60be3c03c8e1e5ae7902a37424c3139ccf566ff1cbc363d176787bd60bb709ef6c56f5b446f1f1b7eca65aa5d431897a0f82a9d6f7fe77fd2ee49f
diff --git a/dev-haskell/parsers/metadata.xml b/dev-haskell/parsers/metadata.xml
new file mode 100644
index 000000000000..0149708d6d5a
--- /dev/null
+++ b/dev-haskell/parsers/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="parsec">Enable the use of the `parsec` package</flag>
+ <flag name="attoparsec">Enable the use of the `attoparsec` package</flag>
+ </use>
+ <longdescription>
+ This library provides convenient combinators for working with and building parsing combinator libraries.
+
+ Given a few simple instances, e.g. for the class &#39;Text.Parser.Combinators.Parsing&#39; in &quot;Text.Parser.Combinators.Parsing&quot; you
+ get access to a large number of canned definitions. Instances exist for the parsers provided by @parsec@,
+ @attoparsec@ and base’s &quot;Text.Read&quot;.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/parsers/parsers-0.12.10.ebuild b/dev-haskell/parsers/parsers-0.12.10.ebuild
new file mode 100644
index 000000000000..a262cb26304a
--- /dev/null
+++ b/dev-haskell/parsers/parsers-0.12.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing combinators"
+HOMEPAGE="https://github.com/ekmett/parsers/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+attoparsec +parsec"
+
+RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/charset-0.3:=[profile?] <dev-haskell/charset-1:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.12:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ attoparsec? ( >=dev-haskell/attoparsec-0.12.1.4:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?] )
+ parsec? ( >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag attoparsec attoparsec) \
+ $(cabal_flag parsec parsec)
+}