summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-13 11:43:42 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:32 +0000
commitdea4a33d89dc9c174aaee97fd6d69d9c5850450e (patch)
tree2bb48022378c43b9707ba3e0ca16603ea9a42c05 /dev-haskell/parsers
parentdev-haskell/parsec: revbump 3.1.14.0-r1 (diff)
downloadgentoo-dea4a33d89dc9c174aaee97fd6d69d9c5850450e.tar.gz
gentoo-dea4a33d89dc9c174aaee97fd6d69d9c5850450e.tar.bz2
gentoo-dea4a33d89dc9c174aaee97fd6d69d9c5850450e.zip
dev-haskell/parsers: revbump 0.12.10-r1
https://github.com/gentoo-haskell/gentoo-haskell/commit/5f6e59982456b919c64e01b279621f6b9ab5be95 Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/parsers')
-rw-r--r--dev-haskell/parsers/Manifest1
-rw-r--r--dev-haskell/parsers/metadata.xml1
-rw-r--r--dev-haskell/parsers/parsers-0.12.10-r1.ebuild57
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-haskell/parsers/Manifest b/dev-haskell/parsers/Manifest
index be0190f33d01..4036465f8724 100644
--- a/dev-haskell/parsers/Manifest
+++ b/dev-haskell/parsers/Manifest
@@ -1 +1,2 @@
+DIST parsers-0.12.10-rev2.cabal 3428 BLAKE2B ff4fa52451f5f85a76dc8a3cd7fecfacfd74bfc5836b46b1c463ff7d021c0f680feedb5816f0cc1e66bc32fddde491c58108fde60d7073bd150b33185c218c76 SHA512 3861ecd2139dadc721b3e3a0ae45f83e488c48b067fc600cffe7b194102e9ac135ce1bbdc8094f10d670367dd5d2571c88b2943be136a682b53d0408d50836b8
DIST parsers-0.12.10.tar.gz 26215 BLAKE2B 35303f6f4919e07b77490f5bcbc2a45efe8fda5edf169ade7dd7cd3bd080f2d24d5470ecb47f8a6428be1176faa8d138616e8f2635f9974ed473c8a61145e8ee SHA512 99ff90de4e60be3c03c8e1e5ae7902a37424c3139ccf566ff1cbc363d176787bd60bb709ef6c56f5b446f1f1b7eca65aa5d431897a0f82a9d6f7fe77fd2ee49f
diff --git a/dev-haskell/parsers/metadata.xml b/dev-haskell/parsers/metadata.xml
index 6c5cd9b30d1d..aa88907fe7af 100644
--- a/dev-haskell/parsers/metadata.xml
+++ b/dev-haskell/parsers/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="parsec">Enable the use of the `parsec` package</flag>
+ <flag name="binary">You can disable the use of the `binary` package using `-f-binary`.</flag>
<flag name="attoparsec">Enable the use of the `attoparsec` package</flag>
</use>
<longdescription>
diff --git a/dev-haskell/parsers/parsers-0.12.10-r1.ebuild b/dev-haskell/parsers/parsers-0.12.10-r1.ebuild
new file mode 100644
index 000000000000..6e0c0d1ebd97
--- /dev/null
+++ b/dev-haskell/parsers/parsers-0.12.10-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="2"
+inherit haskell-cabal
+
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+DESCRIPTION="Parsing combinators"
+HOMEPAGE="https://github.com/ekmett/parsers/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+attoparsec +binary +parsec"
+
+RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/charset-0.3:=[profile?] <dev-haskell/charset-1:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.12:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ attoparsec? ( >=dev-haskell/attoparsec-0.12.1.4:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag attoparsec attoparsec) \
+ $(cabal_flag binary binary) \
+ $(cabal_flag parsec parsec)
+}