summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-05-28 13:54:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-05-28 18:52:59 +0100
commit331df81d2208b4026847f6c91582ff52960dd403 (patch)
tree13fc1ff1e5b04937b6964b79d0e5c7ba6f55e997 /dev-haskell/path/path-0.5.13.ebuild
parentdev-haskell/hpack: new package, a depend of dev-haskell/stack (diff)
downloadgentoo-331df81d2208b4026847f6c91582ff52960dd403.tar.gz
gentoo-331df81d2208b4026847f6c91582ff52960dd403.tar.bz2
gentoo-331df81d2208b4026847f6c91582ff52960dd403.zip
dev-haskell/path: new package, a depend of dev-haskell/stack
Support for well-typed paths Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-haskell/path/path-0.5.13.ebuild')
-rw-r--r--dev-haskell/path/path-0.5.13.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/path/path-0.5.13.ebuild b/dev-haskell/path/path-0.5.13.ebuild
new file mode 100644
index 000000000000..cafe98096f2d
--- /dev/null
+++ b/dev-haskell/path/path-0.5.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.2.9999
+#hackport: flags: -validity
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for well-typed paths"
+HOMEPAGE="http://hackage.haskell.org/package/path"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/exceptions-0.4:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ >=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3
+ >=dev-haskell/mtl-2.0 <dev-haskell/mtl-3 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-validity
+}