summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 11:36:09 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:02:36 +0100
commit178f010e40c2a7dd2aea4d902f9da782374b4613 (patch)
treeda6ffb997c402d34f1a7dae8f750d32c05392dc8 /dev-haskell/path
parentdev-haskell/genvalidity-hspec: add package (diff)
downloadgentoo-178f010e40c2a7dd2aea4d902f9da782374b4613.tar.gz
gentoo-178f010e40c2a7dd2aea4d902f9da782374b4613.tar.bz2
gentoo-178f010e40c2a7dd2aea4d902f9da782374b4613.zip
dev-haskell/path: bump up to 0.7.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/path')
-rw-r--r--dev-haskell/path/Manifest1
-rw-r--r--dev-haskell/path/path-0.7.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/path/Manifest b/dev-haskell/path/Manifest
index ff54a9763b45..82cddbc1a3f3 100644
--- a/dev-haskell/path/Manifest
+++ b/dev-haskell/path/Manifest
@@ -1 +1,2 @@
DIST path-0.5.13.tar.gz 16988 BLAKE2B 4fbc3464f674a15a2dc3c543cbf9d705f9c189224e45c6bb4f180e46483547822ed8a90920c183c756ebcd3529ceaa142b7a644b6e2f28a474e1302827b37204 SHA512 bf1e4750aa025382735f0b8329daa092501f1bbcb25ca3951be653cc3193d19be4339697e966db7dbff7ea2f78b251259c9f6f4cb36402a51221b077af388284
+DIST path-0.7.0.tar.gz 24227 BLAKE2B b2f3347c29dfae0e7674f4de39f07bb7ee681735d1509c7eefd29cc2141dcf974212fc970095a783fdb47dbffaac9489097116768bfe996a160bb9b8886cc9e6 SHA512 b07fc95eab12188d49e4525ea5bbadfda9d5bfb61cc306d624730087d2fc1f946407e4861f7f66de48d9cdf2541591d4518fcc77f28d65671bfa65a963e18a9c
diff --git a/dev-haskell/path/path-0.7.0.ebuild b/dev-haskell/path/path-0.7.0.ebuild
new file mode 100644
index 000000000000..969e56affe31
--- /dev/null
+++ b/dev-haskell/path/path-0.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.3
+#hackport: flags: -validity,-dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for well-typed paths"
+HOMEPAGE="http://hackage.haskell.org/package/path"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/exceptions-0.4:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-8.2.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0.0.2
+ test? ( >=dev-haskell/genvalidity-0.8
+ >=dev-haskell/genvalidity-hspec-0.7
+ >=dev-haskell/genvalidity-property-0.4
+ >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3
+ >=dev-haskell/mtl-2.0 <dev-haskell/mtl-3
+ dev-haskell/quickcheck
+ >=dev-haskell/validity-0.8.0.0 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-dev \
+ --flag=-validity
+}