summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 09:44:49 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:31 +0100
commit3cd3d28eb508c32843db32f70459f314ac737050 (patch)
treeeb93056e42516fb748be4d931da48cd7e431b97c /dev-haskell/persistent-test
parentdev-haskell/microlens-th: add package (diff)
downloadgentoo-3cd3d28eb508c32843db32f70459f314ac737050.tar.gz
gentoo-3cd3d28eb508c32843db32f70459f314ac737050.tar.bz2
gentoo-3cd3d28eb508c32843db32f70459f314ac737050.zip
dev-haskell/persistent-test: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/persistent-test')
-rw-r--r--dev-haskell/persistent-test/Manifest1
-rw-r--r--dev-haskell/persistent-test/files/persistent-test-2.0.3.0-new-exts.patch252
-rw-r--r--dev-haskell/persistent-test/metadata.xml11
-rw-r--r--dev-haskell/persistent-test/persistent-test-2.0.3.0.ebuild47
4 files changed, 311 insertions, 0 deletions
diff --git a/dev-haskell/persistent-test/Manifest b/dev-haskell/persistent-test/Manifest
new file mode 100644
index 000000000000..9c8f14d6ae45
--- /dev/null
+++ b/dev-haskell/persistent-test/Manifest
@@ -0,0 +1 @@
+DIST persistent-test-2.0.3.0.tar.gz 24642 BLAKE2B a1f94ffd7d574ac575db79f2afcd9f627be9dffff8c29811d104b1c30239f0518c90b096a34689c18e9e1a4fa63a3dccb819bd910ecfdadb5239806d53e5cb17 SHA512 511aa72db39687b2b90ef262d5dd83a64887902c2fe57bb87bfd437421170f39af4ebf54ba217eddce80d2afac54ed7e546214775f056e478f20de27c518fdf1
diff --git a/dev-haskell/persistent-test/files/persistent-test-2.0.3.0-new-exts.patch b/dev-haskell/persistent-test/files/persistent-test-2.0.3.0-new-exts.patch
new file mode 100644
index 000000000000..e27746b85731
--- /dev/null
+++ b/dev-haskell/persistent-test/files/persistent-test-2.0.3.0-new-exts.patch
@@ -0,0 +1,252 @@
+--- a/src/CompositeTest.hs
++++ b/src/CompositeTest.hs
+@@ -1,6 +1,8 @@
+ {-# LANGUAGE DeriveGeneric #-}
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-} -- FIXME
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-incomplete-uni-patterns #-}
+ module CompositeTest where
+
+--- a/src/CustomPersistFieldTest.hs
++++ b/src/CustomPersistFieldTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module CustomPersistFieldTest (specsWith, customFieldMigrate) where
+
+--- a/src/CustomPrimaryKeyReferenceTest.hs
++++ b/src/CustomPrimaryKeyReferenceTest.hs
+@@ -1,4 +1,6 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
+ -- This test is based on this issue: https://github.com/yesodweb/persistent/issues/421
+ -- The primary thing this is testing is the migration, thus the test code itself being mostly negligible.
+--- a/src/DataTypeTest.hs
++++ b/src/DataTypeTest.hs
+@@ -1,5 +1,8 @@
+ {-# LANGUAGE ScopedTypeVariables #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module DataTypeTest
+ ( specsWith
+--- a/src/EmbedOrderTest.hs
++++ b/src/EmbedOrderTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module EmbedOrderTest (specsWith, embedOrderMigrate, cleanDB) where
+
+--- a/src/EmbedTest.hs
++++ b/src/EmbedTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-orphans -O0 #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module EmbedTest (specsWith, cleanDB, embedMigrate) where
+--- a/src/EmptyEntityTest.hs
++++ b/src/EmptyEntityTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module EmptyEntityTest (specsWith, migration, cleanDB) where
+
+--- a/src/EntityEmbedTest.hs
++++ b/src/EntityEmbedTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module EntityEmbedTest where
+
+ -- because we are using a type alias we need to declare in a separate module
+--- a/src/EquivalentTypeTest.hs
++++ b/src/EquivalentTypeTest.hs
+@@ -1,4 +1,6 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+
+--- a/src/HtmlTest.hs
++++ b/src/HtmlTest.hs
+@@ -1,4 +1,8 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
++
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module HtmlTest (specsWith, cleanDB, htmlMigrate) where
+
+--- a/src/LargeNumberTest.hs
++++ b/src/LargeNumberTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module LargeNumberTest where
+
+ import Data.Word
+--- a/src/MaxLenTest.hs
++++ b/src/MaxLenTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+
+ module MaxLenTest (specsWith, maxlenMigrate) where
+--- a/src/MigrationColumnLengthTest.hs
++++ b/src/MigrationColumnLengthTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module MigrationColumnLengthTest where
+
+ import qualified Data.Text as T
+--- a/src/MigrationIdempotencyTest.hs
++++ b/src/MigrationIdempotencyTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module MigrationIdempotencyTest where
+
+ import qualified Data.Text as T
+--- a/src/MigrationOnlyTest.hs
++++ b/src/MigrationOnlyTest.hs
+@@ -1,5 +1,8 @@
+ {-# LANGUAGE UndecidableInstances #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module MigrationOnlyTest (specsWith, migrateAll1, migrateAll2) where
+
+ import qualified Data.Text as T
+--- a/src/MigrationTest.hs
++++ b/src/MigrationTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module MigrationTest where
+
+ import Database.Persist.TH
+--- a/src/PersistUniqueTest.hs
++++ b/src/PersistUniqueTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module PersistUniqueTest where
+
+ import Init
+--- a/src/PersistentTestModels.hs
++++ b/src/PersistentTestModels.hs
+@@ -1,6 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE StandaloneDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-} -- FIXME
++{-# LANGUAGE DerivingStrategies #-}
+ module PersistentTestModels where
+
+ import Data.Aeson
+--- a/src/PrimaryTest.hs
++++ b/src/PrimaryTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module PrimaryTest where
+
+ import Init
+--- a/src/Recursive.hs
++++ b/src/Recursive.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module Recursive (specsWith, recursiveMigrate, cleanup) where
+
+--- a/src/RenameTest.hs
++++ b/src/RenameTest.hs
+@@ -1,4 +1,7 @@
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module RenameTest where
+
+ import qualified Data.Map as Map
+--- a/src/SumTypeTest.hs
++++ b/src/SumTypeTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE StandaloneDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# OPTIONS_GHC -Wno-unused-top-binds #-}
+ module SumTypeTest (specsWith, sumTypeMigrate) where
+
+--- a/src/TransactionLevelTest.hs
++++ b/src/TransactionLevelTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+
+ module TransactionLevelTest where
+
+--- a/src/TreeTest.hs
++++ b/src/TreeTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-} -- FIXME
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module TreeTest where
+
+ import Database.Persist.TH (mkDeleteCascade)
+--- a/src/UniqueTest.hs
++++ b/src/UniqueTest.hs
+@@ -1,5 +1,7 @@
+ {-# LANGUAGE GeneralizedNewtypeDeriving #-}
+ {-# LANGUAGE UndecidableInstances #-}
++{-# LANGUAGE DerivingStrategies #-}
++{-# LANGUAGE StandaloneDeriving #-}
+ module UniqueTest where
+
+ import Init
diff --git a/dev-haskell/persistent-test/metadata.xml b/dev-haskell/persistent-test/metadata.xml
new file mode 100644
index 000000000000..06a1d4de2257
--- /dev/null
+++ b/dev-haskell/persistent-test/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Tests for Persistent. This is only for use in developing libraries that should conform to the persistent interface, not for users of the persistent suite of database libraries.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/persistent-test/persistent-test-2.0.3.0.ebuild b/dev-haskell/persistent-test/persistent-test-2.0.3.0.ebuild
new file mode 100644
index 000000000000..31a319f723d7
--- /dev/null
+++ b/dev-haskell/persistent-test/persistent-test-2.0.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Tests for Persistent"
+HOMEPAGE="http://www.yesodweb.com/book/persistent"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ >=dev-haskell/blaze-html-0.9:=[profile?]
+ >=dev-haskell/conduit-1.2.12:=[profile?]
+ >=dev-haskell/exceptions-0.8:=[profile?]
+ >=dev-haskell/hspec-2.4:=[profile?]
+ dev-haskell/hspec-expectations:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/monad-logger-0.3.25:=[profile?]
+ >=dev-haskell/path-pieces-0.2:=[profile?]
+ dev-haskell/persistent:=[profile?]
+ dev-haskell/persistent-template:=[profile?]
+ >=dev-haskell/quickcheck-2.9:2=[profile?]
+ >=dev-haskell/quickcheck-instances-0.3:=[profile?]
+ >=dev-haskell/random-1.1:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+PATCHES=("${FILESDIR}"/${P}-new-exts.patch)