summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-23 12:41:41 +1000
committerSam James <sam@gentoo.org>2022-07-23 05:06:18 +0100
commitb56de72aeb9eba05d78d883e15f8d2958af92350 (patch)
tree3b308c501247bb673bee7e9f9fd69dc5fe0bfb99 /dev-haskell/persistent
parentdev-haskell/lift-type: new package, add 0.1.0.1 (diff)
downloadgentoo-b56de72aeb9eba05d78d883e15f8d2958af92350.tar.gz
gentoo-b56de72aeb9eba05d78d883e15f8d2958af92350.tar.bz2
gentoo-b56de72aeb9eba05d78d883e15f8d2958af92350.zip
dev-haskell/persistent: add 2.14.0.3
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/persistent')
-rw-r--r--dev-haskell/persistent/Manifest1
-rw-r--r--dev-haskell/persistent/persistent-2.14.0.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/persistent/Manifest b/dev-haskell/persistent/Manifest
index 9fdd902d3c5d..2aa1eab14fb3 100644
--- a/dev-haskell/persistent/Manifest
+++ b/dev-haskell/persistent/Manifest
@@ -1 +1,2 @@
DIST persistent-2.10.5.2.tar.gz 72570 BLAKE2B fb5fe4704076e66b6aa24615e4faa14803879b18da6dc972f7f05a5ecc27435ee4e7f46376a2082bb327b189db4cc51aa04f673ffc8df46d8b85a56e2c26b111 SHA512 5d7fe9259d89ab210bd136d9f9b0f3e52d48825a003cc02dfb01f50457324daf2c8659b9123cc0e958b636613fa61004f649f97980c6a5427d425656ceb166f1
+DIST persistent-2.14.0.3.tar.gz 171536 BLAKE2B 2659ebf0acd64a4dde77f8d17f0081676a4215093eaace2f847d8aa7bff736535ca15fe0a7b023a4ec145f4091fa4f3ae9b9dc3b8a77086b44d61d6968ad006b SHA512 63256b0a4e32f5b229e4924f787db3ffa18f40b4101c4610ea51311d6f0b5ac295abfea632bc8cf095de858f19bfe0649c2d2c07289e50ac845e6c945ac172ba
diff --git a/dev-haskell/persistent/persistent-2.14.0.3.ebuild b/dev-haskell/persistent/persistent-2.14.0.3.ebuild
new file mode 100644
index 000000000000..0474df092964
--- /dev/null
+++ b/dev-haskell/persistent/persistent-2.14.0.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+#hackport: flags: -nooverlap
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type-safe, multi-backend data serialization"
+HOMEPAGE="https://www.yesodweb.com/book/persistent"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?] <dev-haskell/aeson-2.1:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-html-0.9:=[profile?]
+ >=dev-haskell/conduit-1.2.12:=[profile?]
+ >=dev-haskell/fast-logger-2.4:=[profile?]
+ >=dev-haskell/http-api-data-0.3:=[profile?]
+ >=dev-haskell/lift-type-0.1.0.0:=[profile?] <dev-haskell/lift-type-0.2.0.0:=[profile?]
+ >=dev-haskell/monad-logger-0.3.28:=[profile?]
+ >=dev-haskell/path-pieces-0.2:=[profile?]
+ >=dev-haskell/resource-pool-0.2.3:=[profile?]
+ >=dev-haskell/resourcet-1.1.10:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/silently:=[profile?]
+ >=dev-haskell/th-lift-instances-0.1.14:=[profile?] <dev-haskell/th-lift-instances-0.2:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vault:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2.4
+ dev-haskell/quickcheck
+ >=dev-haskell/quickcheck-instances-0.3
+ dev-haskell/shakespeare )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-nooverlap
+}