summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/puremd5
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/puremd5')
-rw-r--r--dev-haskell/puremd5/Manifest1
-rw-r--r--dev-haskell/puremd5/metadata.xml9
-rw-r--r--dev-haskell/puremd5/puremd5-2.1.2.1.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/puremd5/Manifest b/dev-haskell/puremd5/Manifest
new file mode 100644
index 000000000000..86b2cb48576c
--- /dev/null
+++ b/dev-haskell/puremd5/Manifest
@@ -0,0 +1 @@
+DIST pureMD5-2.1.2.1.tar.gz 5824 SHA256 6768174686d5eaef76b487f6f8160a932c48012668fbe542e7aba489134956ff SHA512 8a9e8957e4fcea2ec7db014f1dfd153bc00589caf63fa12546b0594a35bbd7bd800decee1a990106515c817dd30f2565454d1e53f2bef87dcf606cc191a0e428 WHIRLPOOL dc2026def1ec8b61dd5bcdd5f8742147b8294b9479fce8500ac703d88f599e21926776a63bd6eb58692310286cbc69651b6928f315ad535103da4db144399cbc
diff --git a/dev-haskell/puremd5/metadata.xml b/dev-haskell/puremd5/metadata.xml
new file mode 100644
index 000000000000..2b631c334729
--- /dev/null
+++ b/dev-haskell/puremd5/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A Haskell-only implementation of the MD5 digest (hash) algorithm. This now supports
+ the crypto-api class interface.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/puremd5/puremd5-2.1.2.1.ebuild b/dev-haskell/puremd5/puremd5-2.1.2.1.ebuild
new file mode 100644
index 000000000000..33573585eefb
--- /dev/null
+++ b/dev-haskell/puremd5/puremd5-2.1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="pureMD5"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Haskell-only implementation of the MD5 digest (hash) algorithm"
+HOMEPAGE="http://hackage.haskell.org/package/pureMD5"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4.0[profile?]
+ >=dev-haskell/cereal-0.2[profile?]
+ dev-haskell/crypto-api[profile?]
+ dev-haskell/tagged[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"