summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:23:37 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:31:16 +0100
commit4a5dcbf34470c6ec171bbb3afd02312953463b8c (patch)
tree6206bd4c1fae321b7cc21a05fa2c58163e9b30d0 /dev-haskell/quickcheck-classes
parentdev-haskell/primitive-addr: new package, a depend of arithmoi-0.11 (diff)
downloadgentoo-4a5dcbf34470c6ec171bbb3afd02312953463b8c.tar.gz
gentoo-4a5dcbf34470c6ec171bbb3afd02312953463b8c.tar.bz2
gentoo-4a5dcbf34470c6ec171bbb3afd02312953463b8c.zip
dev-haskell/quickcheck-classes: new package, a depend of arithmoi-0.11
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/quickcheck-classes')
-rw-r--r--dev-haskell/quickcheck-classes/Manifest1
-rw-r--r--dev-haskell/quickcheck-classes/metadata.xml47
-rw-r--r--dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild54
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck-classes/Manifest b/dev-haskell/quickcheck-classes/Manifest
new file mode 100644
index 000000000000..c6932af438a5
--- /dev/null
+++ b/dev-haskell/quickcheck-classes/Manifest
@@ -0,0 +1 @@
+DIST quickcheck-classes-0.6.4.0.tar.gz 19976 BLAKE2B 614ebc6e1be382a942a55a039921021fd4bcaa2f5c977a8d83bd7b1fb76feebb31f94da908c2389d5f9ab5f7e2481f76223375db41d12b3583658d5d7361ed9b SHA512 2d5786d3cd386a795d5e1ca58ef55fb2efb9285724cf8cbb2f28577973ac2b2a9058ba6185904bc29da88f6d080f4a38629df272502796a0c2e31f9a0e8b658c
diff --git a/dev-haskell/quickcheck-classes/metadata.xml b/dev-haskell/quickcheck-classes/metadata.xml
new file mode 100644
index 000000000000..aaf10d4bc2b5
--- /dev/null
+++ b/dev-haskell/quickcheck-classes/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="aeson">
+ Enable the use of the `aeson` package. This may be useful for
+ accelerating builds in sandboxes for expert users.
+ </flag>
+ <flag name="semigroupoids">
+ Enable the use of the `semigroupoids` package. This may be
+ useful for accelerating builds in sandboxes for expert users.
+ </flag>
+ <flag name="semirings">
+ Enable the use of the `semirings` package. This may be useful
+ for accelerating builds in sandboxes for expert users.
+ </flag>
+ <flag name="vector">
+ Enable the use of the `vector` package. This may be useful
+ for accelerating builds in sandboxes for expert users.
+ </flag>
+ <flag name="unary-laws">
+ Include infrastructure for testing class laws of unary type constructors.
+ </flag>
+ <flag name="binary-laws">
+ Include infrastructure for testing class laws of binary type constructors.
+ Disabling `unary-laws` while keeping `binary-laws` enabled is an unsupported
+ configuration.
+ </flag>
+ </use>
+ <longdescription>
+ This library provides QuickCheck properties to ensure
+ that typeclass instances adhere to the set of laws that
+ they are supposed to. There are other libraries that do
+ similar things, such as `genvalidity-hspec` and `checkers`.
+ This library differs from other solutions by not introducing
+ any new typeclasses that the user needs to learn.
+
+ /Note:/ on GHC &lt; 8.5, this library uses the higher-kinded typeclasses
+ (&#39;Data.Functor.Classes.Show1&#39;, &#39;Data.Functor.Classes.Eq1&#39;, &#39;Data.Functor.Classes.Ord1&#39;, etc.),
+ but on GHC &gt;= 8.5, it uses `-XQuantifiedConstraints` to express these
+ constraints more cleanly.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild b/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild
new file mode 100644
index 000000000000..e4dbaa884075
--- /dev/null
+++ b/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck common typeclasses"
+HOMEPAGE="https://github.com/andrewthad/quickcheck-classes#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+aeson +binary-laws +semigroupoids +semirings +unary-laws +vector"
+
+RDEPEND=">=dev-haskell/base-orphans-0.1:=[profile?]
+ dev-haskell/bifunctors:=[profile?]
+ dev-haskell/contravariant:=[profile?]
+ dev-haskell/fail:=[profile?]
+ >=dev-haskell/primitive-0.6.4:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/primitive-addr-0.1.0.2:=[profile?] <dev-haskell/primitive-addr-0.2:=[profile?]
+ >=dev-haskell/quickcheck-classes-base-0.6:=[profile?] <dev-haskell/quickcheck-classes-base-0.7:=[profile?]
+ >=dev-haskell/semigroups-0.17:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ aeson? ( >=dev-haskell/aeson-0.9:=[profile?] )
+ binary-laws? ( >=dev-haskell/quickcheck-2.10.0:2=[profile?] )
+ semigroupoids? ( dev-haskell/semigroupoids:=[profile?] )
+ semirings? ( >=dev-haskell/semirings-0.4.2:=[profile?] )
+ unary-laws? ( >=dev-haskell/quickcheck-2.10.0:2=[profile?] )
+ !unary-laws? ( !binary-laws? ( >=dev-haskell/quickcheck-2.7:2=[profile?] ) )
+ vector? ( >=dev-haskell/vector-0.12:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/base-orphans-0.5
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck
+ !vector? ( dev-haskell/vector ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag aeson aeson) \
+ $(cabal_flag binary-laws binary-laws) \
+ $(cabal_flag semigroupoids semigroupoids) \
+ $(cabal_flag semirings semirings) \
+ $(cabal_flag unary-laws unary-laws) \
+ $(cabal_flag vector vector)
+}