summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-30 23:11:16 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-30 23:11:28 +0100
commit1e49c6071eb11295812710851f3c75087426bc34 (patch)
treeb3f59def293abdd9a24d27a4d8defcf8893685e0 /dev-haskell/reflection
parentdev-haskell/reflection: bump up to 2.1.6 (diff)
downloadgentoo-1e49c6071eb11295812710851f3c75087426bc34.tar.gz
gentoo-1e49c6071eb11295812710851f3c75087426bc34.tar.bz2
gentoo-1e49c6071eb11295812710851f3c75087426bc34.zip
dev-haskell/reflection: drop old
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/reflection')
-rw-r--r--dev-haskell/reflection/Manifest1
-rw-r--r--dev-haskell/reflection/metadata.xml44
-rw-r--r--dev-haskell/reflection/reflection-2.1.4.ebuild33
3 files changed, 0 insertions, 78 deletions
diff --git a/dev-haskell/reflection/Manifest b/dev-haskell/reflection/Manifest
index 7ba0108437ed..e36a6080bc8b 100644
--- a/dev-haskell/reflection/Manifest
+++ b/dev-haskell/reflection/Manifest
@@ -1,2 +1 @@
-DIST reflection-2.1.4.tar.gz 18364 BLAKE2B 70cf5fc742deac5555be43a24b2b74930e54a7909e68dea53d8dba7b4547b99d97dbb361ae96776a54a7305069305ea085d8d988b70b86460bd476af6392c417 SHA512 3209bb44a07fedddbb2aeb5f2f09414e6672faff6c8fbdb78eaa8f61a1af4d9fba43be193854f8978ffdd82c0ce54bd79a5d875638a41b6a738bc489bd718295
DIST reflection-2.1.6.tar.gz 19976 BLAKE2B 6e32e9300695b102be4039312b3df62bccce75a590eafa37d96d70cbf73acfc4be98bc716485235e4594548b8649b46bb554eacc230320abc2d92dd809f15176 SHA512 d7f615b6f361b2ca7266e8c4611c939d9f80684ca173080e9ad8227f04f2731899113dcb87ecb051d47b29fb860d7caa15c99c7d3d7493e7e73745d085518fdd
diff --git a/dev-haskell/reflection/metadata.xml b/dev-haskell/reflection/metadata.xml
index 0845fb397e13..81f795d4050f 100644
--- a/dev-haskell/reflection/metadata.xml
+++ b/dev-haskell/reflection/metadata.xml
@@ -5,50 +5,6 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package provides an implementation of the ideas presented in the paper
- \"Functional Pearl: Implicit Configurations\" by Oleg Kiselyov and
- Chung-chieh Shan. However, the API has been streamlined to improve performance.
-
- The original paper can be obtained from
- &lt;http://www.cs.rutgers.edu/~ccshan/prepose/prepose.pdf&gt;.
-
- /Changes in 1.1.6/:
-
- * Relaxed an unnecessary strictness annotation in the fast implementation
-
- /Changes in 1.1.5/:
-
- * Both implementations now work on Hugs; the fast implementation ascends
- from the ranks of completely unportable black magic to being merely
- /mostly/ unportable black magic.
-
- /Changes from 0.5 to 1.1/:
-
- * Much faster implementation available that is about 50 /times/ faster than
- 0.9 and which runs purely on black magic. This version is now used by
- default. To turn it off install with the @slow@ flag. If you encounter a
- problem with the implementation, please contact the author.
-
- * Removed @ReifiedNum@, @reflectNum@, and @reifyIntegral@; @reify@ and
- @reflect@ are about 3 orders of magnitude faster than the special case
- combinators were.
-
- /Changes in 0.5/:
-
- * Generalized the type signatures in reflect to allow you to pass any type
- with kind @* -&gt; *@ wrapped around the desired type as the phantom type
- argument rather than just a @Proxy@.
-
- /Changes in 0.4/:
-
- * Converted from `Data.Tagged` to using `Data.Proxy` for reflection. This
- reduces the need for helper functions and scoped type variables in user
- code.
- </longdescription>
- <use>
- <flag name="template-haskell">Enable template haskell.</flag>
- </use>
<upstream>
<remote-id type="github">ekmett/reflection</remote-id>
</upstream>
diff --git a/dev-haskell/reflection/reflection-2.1.4.ebuild b/dev-haskell/reflection/reflection-2.1.4.ebuild
deleted file mode 100644
index 6330682ad3d4..000000000000
--- a/dev-haskell/reflection/reflection-2.1.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.5.6.9999
-#hackport: flags: -slow
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Reifies arbitrary terms into types that can be reflected back into terms"
-HOMEPAGE="https://github.com/ekmett/reflection"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+template-haskell"
-
-RDEPEND=">=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
- >=dev-haskell/tagged-0.4.4:=[profile?] <dev-haskell/tagged-1:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-slow \
- $(cabal_flag template-haskell template-haskell)
-}