summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/sendfile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/sendfile')
-rw-r--r--dev-haskell/sendfile/Manifest1
-rw-r--r--dev-haskell/sendfile/metadata.xml13
-rw-r--r--dev-haskell/sendfile/sendfile-0.7.9.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/sendfile/Manifest b/dev-haskell/sendfile/Manifest
new file mode 100644
index 000000000000..f56fe573d8df
--- /dev/null
+++ b/dev-haskell/sendfile/Manifest
@@ -0,0 +1 @@
+DIST sendfile-0.7.9.tar.gz 10656 SHA256 102fdf6db8c00f5a5981c6eed5acba1368a2d79b2970ce5b22ceb180aa0fdc42 SHA512 a7ba2e82c30b12e5b7f317e2f5cc31c32cb7f682403c3807afc15254d86c3ebb526a645234d191d5b43adc414704caa4cdf61e8083e0a3d53e1af676619f731e WHIRLPOOL 22bfcd58f2e2b0c18782f35468e2412ef84201ead6a6df3142d54099e9f32566a56434326dbdfafdf31e0d211640cbb27b7d28f2780c76adc69f9e47d09b5f83
diff --git a/dev-haskell/sendfile/metadata.xml b/dev-haskell/sendfile/metadata.xml
new file mode 100644
index 000000000000..3d0eaf5322f1
--- /dev/null
+++ b/dev-haskell/sendfile/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A library which exposes zero-copy sendfile functionality in a portable way. If a platform does not support sendfile, a fallback implementation in haskell is provided.
+
+ Currently supported platforms: Windows 2000+ (Native), Linux 2.6+ (Native), FreeBSD (Native), OS-X 10.5+ (Native), Everything else (Portable Haskell code).
+ </longdescription>
+ <use>
+ <flag name="portable">Explicitly enable portable sendfile support (implemented in Haskell)</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-haskell/sendfile/sendfile-0.7.9.ebuild b/dev-haskell/sendfile/sendfile-0.7.9.ebuild
new file mode 100644
index 000000000000..1d31a83a2858
--- /dev/null
+++ b/dev-haskell/sendfile/sendfile-0.7.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A portable sendfile library"
+HOMEPAGE="http://hub.darcs.net/stepcut/sendfile"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="portable"
+
+RDEPEND="=dev-haskell/network-2*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag portable portable)
+}