summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:08:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit3c4aaf63698662899a0d75ca6d9d345e67642051 (patch)
treec7c62362f81715d135e9e8ba2395219ebcf985ff /dev-haskell/shelly/shelly-1.6.5.ebuild
parentdev-haskell/shakespeare: bump up to 2.0.7 (diff)
downloadgentoo-3c4aaf63698662899a0d75ca6d9d345e67642051.tar.gz
gentoo-3c4aaf63698662899a0d75ca6d9d345e67642051.tar.bz2
gentoo-3c4aaf63698662899a0d75ca6d9d345e67642051.zip
dev-haskell/shelly: bump up to 1.6.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/shelly/shelly-1.6.5.ebuild')
-rw-r--r--dev-haskell/shelly/shelly-1.6.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/shelly/shelly-1.6.5.ebuild b/dev-haskell/shelly/shelly-1.6.5.ebuild
new file mode 100644
index 000000000000..388277448359
--- /dev/null
+++ b/dev-haskell/shelly/shelly-1.6.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="shell-like (systems) programming in Haskell"
+HOMEPAGE="https://github.com/yesodweb/Shelly.hs"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lifted"
+
+RDEPEND="dev-haskell/async:=[profile?]
+ dev-haskell/enclosed-exceptions:=[profile?]
+ >=dev-haskell/exceptions-0.6:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ dev-haskell/lifted-async:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/monad-control-0.3.2:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/system-fileio-0.4:=[profile?]
+ >=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.5
+ >=dev-haskell/hunit-1.2
+ >=dev-haskell/text-0.11 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lifted lifted)
+}