summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/smallcheck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/smallcheck')
-rw-r--r--dev-haskell/smallcheck/Manifest2
-rw-r--r--dev-haskell/smallcheck/metadata.xml14
-rw-r--r--dev-haskell/smallcheck/smallcheck-1.0.4.ebuild25
-rw-r--r--dev-haskell/smallcheck/smallcheck-1.1.1.ebuild27
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/smallcheck/Manifest b/dev-haskell/smallcheck/Manifest
new file mode 100644
index 000000000000..de9d499b7363
--- /dev/null
+++ b/dev-haskell/smallcheck/Manifest
@@ -0,0 +1,2 @@
+DIST smallcheck-1.0.4.tar.gz 14200 SHA256 fff411375b39e1806e8a342371bc4846e178891b5ab74e437c679a920fd71a7f SHA512 5184ed016acd0c3f5b6c067cbb1a935188f1818f20652fce8c2730e7deadb00fa2cd64b5b71613a3d252fe0571e77cdf51288244899c08eb63ff2b1880d2b1bf WHIRLPOOL e13b1e07fcbc730ceda34a0cf73869e3a661c0863c367bb61c771ace5ac406dc0c88e5950022efb26d3e3dd5b8f7027335bac10b599be1eb7a73d873108c2ca1
+DIST smallcheck-1.1.1.tar.gz 15202 SHA256 4d17607c1a620491e7e495a17575b73952932c761e7f9bdfa87e0102fb52f9f9 SHA512 09aa5dcfca2bece6ac91803d38f2591d415c6e312c76cacb33d2e93e40e949acb788bc89ba6a4beb9dc60815e1f554cda4f68195269eedbfb45228415f1bca64 WHIRLPOOL edf7339615602eb61b5df3678c08959bdb8e78c8fcf7fa33539021d0751b3c37f2e79c8e2b3fbfca55967e1b76c1162ed194a946a1e96969b16e9eed4895237d
diff --git a/dev-haskell/smallcheck/metadata.xml b/dev-haskell/smallcheck/metadata.xml
new file mode 100644
index 000000000000..48f179deb48f
--- /dev/null
+++ b/dev-haskell/smallcheck/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ SmallCheck is similar to QuickCheck (Claessen and Hughes 2000-) but
+ instead of testing for a sample of randomly generated values, SmallCheck
+ tests properties for all the finitely many values up to some depth,
+ progressively increasing the depth used.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">feuerbach/smallcheck</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/smallcheck/smallcheck-1.0.4.ebuild b/dev-haskell/smallcheck/smallcheck-1.0.4.ebuild
new file mode 100644
index 000000000000..3103d41ca5e6
--- /dev/null
+++ b/dev-haskell/smallcheck/smallcheck-1.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A property-based testing library"
+HOMEPAGE="https://github.com/feuerbach/smallcheck"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/logict:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/smallcheck/smallcheck-1.1.1.ebuild b/dev-haskell/smallcheck/smallcheck-1.1.1.ebuild
new file mode 100644
index 000000000000..1b6ffc375c76
--- /dev/null
+++ b/dev-haskell/smallcheck/smallcheck-1.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A property-based testing library"
+HOMEPAGE="https://github.com/feuerbach/smallcheck"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/logict:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"