summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/stmonadtrans
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/stmonadtrans')
-rw-r--r--dev-haskell/stmonadtrans/Manifest2
-rw-r--r--dev-haskell/stmonadtrans/metadata.xml14
-rw-r--r--dev-haskell/stmonadtrans/stmonadtrans-0.3.2.ebuild31
-rw-r--r--dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild31
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-haskell/stmonadtrans/Manifest b/dev-haskell/stmonadtrans/Manifest
new file mode 100644
index 000000000000..2e49db164f5f
--- /dev/null
+++ b/dev-haskell/stmonadtrans/Manifest
@@ -0,0 +1,2 @@
+DIST STMonadTrans-0.3.2.tar.gz 4792 SHA256 70be84c06ce312a56dbf37d674ad709700850b7fd4cb55198d7ae45a985e85b2 SHA512 d16fb73fd083ab68ad2bed75dbc04754a624acc2cc5cb2731d09b7bb3b35e9263dd76976ff0221736d8813d17a795b58acae5fa1c6688a421c8be78f966afa60 WHIRLPOOL a8e01fd2262c1b5f1538254e0d3f8c5536fb86763eb1de6861f256b44b6c10661e50ff1f9ef09c1450ea8c88487e92ca2768251a0dcac0bf80448fe8eb64ce11
+DIST STMonadTrans-0.3.3.tar.gz 4820 SHA256 d9911c7634c42b94f57ac7c2a6d523f6d7124870b35fc3030cb72109ba3aa315 SHA512 5395dfac66abcf75593b5c62252b452e4935b85e294a1f9b4a40424b29be76109b89b0cc35eaa15bd448a4d51ae0500bfe72924db854e02e949685fd9180d847 WHIRLPOOL 7d038fafc793e74910444ac04bf9cd038aaee7476ba033ac6afef160b626e82b54add16e37ecc9d9f330351d8c61782c1006094113e275133be97d20c7f35c2a
diff --git a/dev-haskell/stmonadtrans/metadata.xml b/dev-haskell/stmonadtrans/metadata.xml
new file mode 100644
index 000000000000..d67126646e2c
--- /dev/null
+++ b/dev-haskell/stmonadtrans/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A monad transformer version of the ST monad
+ Warning! This monad transformer should not be used with monads that
+ can contain multiple answers, like the list monad. The reason is that
+ the will be duplicated across the different answers and this cause
+ Bad Things to happen (such as loss of referential transparency). Safe
+ monads include the monads State, Reader, Writer, Maybe and
+ combinations of their corresponding monad transformers.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/stmonadtrans/stmonadtrans-0.3.2.ebuild b/dev-haskell/stmonadtrans/stmonadtrans-0.3.2.ebuild
new file mode 100644
index 000000000000..fb1582f5d970
--- /dev/null
+++ b/dev-haskell/stmonadtrans/stmonadtrans-0.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="STMonadTrans"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A monad transformer version of the ST monad"
+HOMEPAGE="http://hackage.haskell.org/package/STMonadTrans"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild b/dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild
new file mode 100644
index 000000000000..b6a5ea100f19
--- /dev/null
+++ b/dev-haskell/stmonadtrans/stmonadtrans-0.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="STMonadTrans"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A monad transformer version of the ST monad"
+HOMEPAGE="http://hackage.haskell.org/package/STMonadTrans"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"