summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-10 21:57:22 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commit42005da3651c15a3b2f2eae82c43310e5127554f (patch)
tree0fd25a6088d8cb59e6b652ef209a387bb1f6df96 /dev-haskell/tagsoup/tagsoup-0.13.10.ebuild
parentdev-haskell/statevar: bump up to 1.1.0.4 (diff)
downloadgentoo-42005da3651c15a3b2f2eae82c43310e5127554f.tar.gz
gentoo-42005da3651c15a3b2f2eae82c43310e5127554f.tar.bz2
gentoo-42005da3651c15a3b2f2eae82c43310e5127554f.zip
dev-haskell/tagsoup: bump up to 0.13.10
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-haskell/tagsoup/tagsoup-0.13.10.ebuild')
-rw-r--r--dev-haskell/tagsoup/tagsoup-0.13.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/tagsoup/tagsoup-0.13.10.ebuild b/dev-haskell/tagsoup/tagsoup-0.13.10.ebuild
new file mode 100644
index 000000000000..b950921dbb99
--- /dev/null
+++ b/dev-haskell/tagsoup/tagsoup-0.13.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing and extracting information from (possibly malformed) HTML/XML documents"
+HOMEPAGE="https://github.com/ndmitchell/tagsoup#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="download testprog"
+
+RDEPEND="dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ download? ( dev-haskell/network:=[profile?] )
+ testprog? ( >=dev-haskell/quickcheck-2.4:2=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag download download) \
+ $(cabal_flag testprog testprog)
+}