summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 17:36:59 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:50 +0000
commitf2fbb750b6aafa0042bc92a86ef3010eee5cecfc (patch)
treedbbe9c32c2f3be385510c302dc34148172c44606 /dev-haskell/test-framework
parentdev-haskell/test-framework-hunit: keyword 0.3.0.2-r1 for ~ppc64 (diff)
downloadgentoo-f2fbb750b6aafa0042bc92a86ef3010eee5cecfc.tar.gz
gentoo-f2fbb750b6aafa0042bc92a86ef3010eee5cecfc.tar.bz2
gentoo-f2fbb750b6aafa0042bc92a86ef3010eee5cecfc.zip
dev-haskell/test-framework: revbump 0.8.2.0-r3
https://github.com/gentoo-haskell/gentoo-haskell/commit/0c0ee9eaac04188e7e1329cfa57ffb34c7580f82 Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/test-framework')
-rw-r--r--dev-haskell/test-framework/test-framework-0.8.2.0-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/test-framework/test-framework-0.8.2.0-r3.ebuild b/dev-haskell/test-framework/test-framework-0.8.2.0-r3.ebuild
new file mode 100644
index 000000000000..1d18700a0b58
--- /dev/null
+++ b/dev-haskell/test-framework/test-framework-0.8.2.0-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: missing modules
+inherit haskell-cabal
+
+DESCRIPTION="Framework for running and organising tests, with HUnit and QuickCheck support"
+HOMEPAGE="http://haskell.github.io/test-framework/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RESTRICT="test" # tests are missing
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0:=[profile?]
+ >=dev-haskell/ansi-wl-pprint-0.5.1:=[profile?] <dev-haskell/ansi-wl-pprint-0.7:=[profile?]
+ >=dev-haskell/base-orphans-0.1:=[profile?]
+ >=dev-haskell/hostname-1.0:=[profile?] <dev-haskell/hostname-1.1:=[profile?]
+ >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/regex-posix-0.72:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?]
+ >=dev-haskell/xml-1.3.5:=[profile?] <dev-haskell/xml-1.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'ansi-terminal >= 0.4.0 && < 0.9' 'ansi-terminal >= 0.4.0' \
+ 'base-orphans >= 0.1 && < 0.5' 'base-orphans >= 0.1' \
+ 'containers >= 0.1 && < 0.6' 'containers >= 0.1' \
+ 'semigroups >= 0.18 && < 0.19' 'semigroups >= 0.18' \
+ 'QuickCheck >= 2.3 && < 2.10' 'QuickCheck >= 2.3' \
+ 'regex-posix >= 0.72 && < 0.96' 'regex-posix >= 0.72' \
+ 'time >= 1.1.2 && < 1.9' 'time >= 1.1.2' \
+ 'random >= 1.0 && < 1.2' 'random >= 1.0'
+}