summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:16:42 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:18:08 +0100
commita915aa6e6461f8995824e2f15c5e16ea7764744f (patch)
treead2f4ccc051f40f200135f9d0bf75775e8cb76a1 /dev-haskell/testing-type-modifiers
parentdev-haskell/size-based: new pachage, a depend of testing-feat-1.1 (diff)
downloadgentoo-a915aa6e6461f8995824e2f15c5e16ea7764744f.tar.gz
gentoo-a915aa6e6461f8995824e2f15c5e16ea7764744f.tar.bz2
gentoo-a915aa6e6461f8995824e2f15c5e16ea7764744f.zip
dev-haskell/testing-type-modifiers: new pachage, a depend of testing-feat-1.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/testing-type-modifiers')
-rw-r--r--dev-haskell/testing-type-modifiers/Manifest1
-rw-r--r--dev-haskell/testing-type-modifiers/metadata.xml24
-rw-r--r--dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild24
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/testing-type-modifiers/Manifest b/dev-haskell/testing-type-modifiers/Manifest
new file mode 100644
index 000000000000..bd6c2430b09c
--- /dev/null
+++ b/dev-haskell/testing-type-modifiers/Manifest
@@ -0,0 +1 @@
+DIST testing-type-modifiers-0.1.0.1.tar.gz 2275 BLAKE2B 664760d4655f7c4ae4fea0b52f1687b81a754ec9d24aa940600279e6b029924b9505b29f24d7dfd07f6100e99b263727186ec8b65bd48b3d953be7554448c50b SHA512 21b76e469f2af199593a90579e9e2f0105444f508a3b244872936c95b28574cb8a782d74244249e4cf045d885b6878d8ae237ccd578c755f7314336137da56b8
diff --git a/dev-haskell/testing-type-modifiers/metadata.xml b/dev-haskell/testing-type-modifiers/metadata.xml
new file mode 100644
index 000000000000..a475c390c584
--- /dev/null
+++ b/dev-haskell/testing-type-modifiers/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Property based testing libraries such as QuickCheck tend to include type modifiers. Most of them
+ are used to quantify over subsets of a type. For example a property on non-empty lists:
+
+ @ prop_tail_length (NonEmpty xs) = length (tail xs) == length xs - 1 @
+
+ This library is intended to supply these modifiers to be used by testing libraries, in an effort to make
+ properties more portable between testing frameworks.
+
+ For every modifier it also provides an access function that converts to the underlying type, which
+ enables point-free style properties as such:
+
+ @
+ prop_tail_length2 = (&gt; 0) . length . nonEmpty
+ @
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild b/dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild
new file mode 100644
index 000000000000..4d6f60eac4d4
--- /dev/null
+++ b/dev-haskell/testing-type-modifiers/testing-type-modifiers-0.1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data type modifiers for property based testing"
+HOMEPAGE="http://hackage.haskell.org/package/testing-type-modifiers"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"