summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-09-21 18:23:11 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-21 23:07:35 +0100
commit5c8c1cf2fefafd048425f0f9b1124cff1323d7e8 (patch)
tree76babf2a85ab0bce6def8b7b67a2589631f3bf7f /dev-haskell/texmath
parentdev-haskell/regex-pcre-builtin: drop old (diff)
downloadgentoo-5c8c1cf2fefafd048425f0f9b1124cff1323d7e8.tar.gz
gentoo-5c8c1cf2fefafd048425f0f9b1124cff1323d7e8.tar.bz2
gentoo-5c8c1cf2fefafd048425f0f9b1124cff1323d7e8.zip
dev-haskell/texmath: bump up to 0.12.0.3
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/texmath')
-rw-r--r--dev-haskell/texmath/Manifest1
-rw-r--r--dev-haskell/texmath/texmath-0.12.0.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/texmath/Manifest b/dev-haskell/texmath/Manifest
index 0d757969b42b..cd18604c0a14 100644
--- a/dev-haskell/texmath/Manifest
+++ b/dev-haskell/texmath/Manifest
@@ -1 +1,2 @@
DIST texmath-0.12.0.2.tar.gz 1792597 BLAKE2B 17981e435d870a4640f6a773be02e99dbaee295a420b11f90f357b9b483e9b8f5ff3b0363178b9fc57afbf7ff99328454af9c6ae8606a194a57d72ddbef968e0 SHA512 d5b3418492495f59b493bc418e68f4e66f7d2b4eb1293b540b1eb00312a7cded7eb4dba9b178224d311a1999fefac49b5cbb5caa50a85296292cb35d5806dfc6
+DIST texmath-0.12.0.3.tar.gz 1792577 BLAKE2B 0c5ecb7cc49a53ad0ce54755a2a8518066223733b51287013d6e649fdb94b022a9ab81ceb3bb42b80b84bf75e9aa0088adbafe76e147d5314907d8aeb6be9a8e SHA512 54b4789559dc7c6973854c290b018e7c00dd0ff1c06d8045b5d0a2304436bb59a951e93ab2c9d1d133a9d7c5197cc456334d40dc112c6c6a8f8e9370ab8aa190
diff --git a/dev-haskell/texmath/texmath-0.12.0.3.ebuild b/dev-haskell/texmath/texmath-0.12.0.3.ebuild
new file mode 100644
index 000000000000..9ac897e1ba4e
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.12.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between formats used to represent mathematics"
+HOMEPAGE="https://github.com/jgm/texmath"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable +network-uri"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.20:=[profile?] <dev-haskell/pandoc-types-1.23:=[profile?]
+ >=dev-haskell/parsec-3:=[profile?]
+ >=dev-haskell/syb-0.4.2:=[profile?] <dev-haskell/syb-0.8:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ executable? ( dev-haskell/aeson:=[profile?]
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/temporary
+ dev-haskell/utf8-string )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag network-uri network-uri)
+}