summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-13 11:50:36 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:51 +0000
commitbc819e9843d44e257070f29f0a6d9cb1334df8aa (patch)
treeaf7578dae9a5a08e571984739e55907ee566d54a /dev-haskell/texmath
parentdev-haskell/test-framework-quickcheck2: revbump 0.3.0.5-r2 (diff)
downloadgentoo-bc819e9843d44e257070f29f0a6d9cb1334df8aa.tar.gz
gentoo-bc819e9843d44e257070f29f0a6d9cb1334df8aa.tar.bz2
gentoo-bc819e9843d44e257070f29f0a6d9cb1334df8aa.zip
dev-haskell/texmath: add 0.12.5.1
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/texmath')
-rw-r--r--dev-haskell/texmath/Manifest1
-rw-r--r--dev-haskell/texmath/metadata.xml1
-rw-r--r--dev-haskell/texmath/texmath-0.12.5.1.ebuild50
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/texmath/Manifest b/dev-haskell/texmath/Manifest
index 8d0499183ceb..7d0c8ea0fbd6 100644
--- a/dev-haskell/texmath/Manifest
+++ b/dev-haskell/texmath/Manifest
@@ -1 +1,2 @@
DIST texmath-0.12.2.tar.gz 1807359 BLAKE2B 31da9ba7186eb9140c2fe70ba7011e91c00c290ef4b099197cdfb81ee2b992bae73756973b77d6920cabadef71739eb7208136fd2a589f9b81a6afaa338b296b SHA512 89f3dc5c1042980abf06f1e4d3ca6806922f2094c6d7ec2cc1e4673ac16a7aaf73693c5fa5526eac96d6f9f5c2f894f2341295bacebb7216ef49eb8be7cc0424
+DIST texmath-0.12.5.1.tar.gz 1606982 BLAKE2B a58e033176a6a9ba136590b8403d577c24c84cab983a6ee53ba2ae4564c05b681a31859aa066a3cb5aa3b18b07eaee9266964018abc8c30cc9288df15160d8f4 SHA512 77f3b008b82a8a1946108f8bb948d5d43121bffe2b2e22220cc8eb404884fa4c960bff07d7c8a5c75d5cce53d4039a8e6edd190fc69f5ad4da5b41212751f897
diff --git a/dev-haskell/texmath/metadata.xml b/dev-haskell/texmath/metadata.xml
index 46826791c1c0..7364f9dbea9b 100644
--- a/dev-haskell/texmath/metadata.xml
+++ b/dev-haskell/texmath/metadata.xml
@@ -21,6 +21,7 @@
<use>
<flag name="executable">Compile test executable.</flag>
<flag name="network-uri">Get Network.URI from the network-uri package.</flag>
+ <flag name="server">Compile webserver.</flag>
</use>
<upstream>
<remote-id type="github">jgm/texmath</remote-id>
diff --git a/dev-haskell/texmath/texmath-0.12.5.1.ebuild b/dev-haskell/texmath/texmath-0.12.5.1.ebuild
new file mode 100644
index 000000000000..cb2d7665c99a
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.12.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +network-uri
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between math formats"
+HOMEPAGE="https://github.com/jgm/texmath"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="executable server"
+
+RDEPEND=">=dev-haskell/pandoc-types-1.20:=[profile?] <dev-haskell/pandoc-types-1.23:=[profile?]
+ dev-haskell/split:=[profile?]
+ >=dev-haskell/syb-0.4.2:=[profile?] <dev-haskell/syb-0.8:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ executable? ( dev-haskell/aeson:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ dev-haskell/pretty-show:=[profile?] )
+ !executable? ( server? ( dev-haskell/aeson:=[profile?] ) )
+ server? ( dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/servant-server:=[profile?]
+ dev-haskell/wai:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ dev-haskell/warp:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/tagged
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ !executable? ( dev-haskell/pretty-show ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ --flag=network-uri \
+ $(cabal_flag server server)
+}