summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 12:51:41 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:59 +0100
commitef8e0c871f15f9d66a0350da31a9a1d6545ddda9 (patch)
treed3116b7ff2207849b46a65786d8c28e822457119 /dev-haskell/texmath
parentdev-haskell/tagsoup: bump up to 0.14.8 (diff)
downloadgentoo-ef8e0c871f15f9d66a0350da31a9a1d6545ddda9.tar.gz
gentoo-ef8e0c871f15f9d66a0350da31a9a1d6545ddda9.tar.bz2
gentoo-ef8e0c871f15f9d66a0350da31a9a1d6545ddda9.zip
dev-haskell/texmath: bump up to 0.12.0.2
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/texmath')
-rw-r--r--dev-haskell/texmath/Manifest1
-rw-r--r--dev-haskell/texmath/texmath-0.12.0.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/texmath/Manifest b/dev-haskell/texmath/Manifest
index 90aa1fa31dd8..026f84289d83 100644
--- a/dev-haskell/texmath/Manifest
+++ b/dev-haskell/texmath/Manifest
@@ -1,3 +1,4 @@
+DIST texmath-0.12.0.2.tar.gz 1792597 BLAKE2B 17981e435d870a4640f6a773be02e99dbaee295a420b11f90f357b9b483e9b8f5ff3b0363178b9fc57afbf7ff99328454af9c6ae8606a194a57d72ddbef968e0 SHA512 d5b3418492495f59b493bc418e68f4e66f7d2b4eb1293b540b1eb00312a7cded7eb4dba9b178224d311a1999fefac49b5cbb5caa50a85296292cb35d5806dfc6
DIST texmath-0.6.4.tar.gz 45075 BLAKE2B 3272642b243d693d0cad77b71c1caa9cb3131ca90ea3e047b8944e931885cb778571c25da25ad5f0bad70ee9cbfb029ae3dff1a25a2722f311e300960b8601a5 SHA512 b6d1ff64cd7c758687efd656a8e0efdc9b6a1eac9f0dde5cd5d7d07fe6b3c8fd1a62145413b950b443cddd2a434151bc490148631b75fc853bdaadab2b5b0640
DIST texmath-0.6.6.3.tar.gz 46983 BLAKE2B ceb6881b7dacd496d252c6a911407d30194254b157d6e84a640dd447646849cfd8ac24f78ecdc848e1cc280cc2084b73403d12ab809f1abbd6b12f8a826a2f5d SHA512 f6e41b28445751a2d296c9d0effaa95bc4962bb7af037ce277a4b59c0eb8e83caf7389cc420e4839b3737764c2bd7c15277771afdadfbb4310112e9ba5477210
DIST texmath-0.8.2.2.tar.gz 1599187 BLAKE2B f65be60aee417cea0ec9d8e20e257a39de3f64a0288376914f63980c3f13def3473820f0b696f5eb11f210dec80f6d7ceae7c7eced8a64bbd42af712717271fc SHA512 2c8806ab0386acec6ed963a4574a5a24a07eb49a833a51021fef48e3a975012a083bd43fc4172399265430d9599b79f3ce1e5edfe785e80e92f259efc9dc674e
diff --git a/dev-haskell/texmath/texmath-0.12.0.2.ebuild b/dev-haskell/texmath/texmath-0.12.0.2.ebuild
new file mode 100644
index 000000000000..f2eb0bc48628
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.12.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between formats used to represent mathematics"
+HOMEPAGE="https://github.com/jgm/texmath"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable +network-uri"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.20:=[profile?] <dev-haskell/pandoc-types-1.22:=[profile?]
+ >=dev-haskell/parsec-3:=[profile?]
+ >=dev-haskell/syb-0.4.2:=[profile?] <dev-haskell/syb-0.8:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ executable? ( dev-haskell/aeson:=[profile?]
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/temporary
+ dev-haskell/utf8-string )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag network-uri network-uri)
+}