summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 12:42:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 12:42:58 +0000
commiteac19dd933bc244b78eaef04c8eff413ad7a2b2f (patch)
tree4c4f802763b68e1e9c44a9c9d805ec1b695df749 /dev-haskell/th-utilities
parentdev-haskell/threads: bump up to 0.5.1.6 (diff)
downloadgentoo-eac19dd933bc244b78eaef04c8eff413ad7a2b2f.tar.gz
gentoo-eac19dd933bc244b78eaef04c8eff413ad7a2b2f.tar.bz2
gentoo-eac19dd933bc244b78eaef04c8eff413ad7a2b2f.zip
dev-haskell/th-utilities: bump up to 0.2.3.0
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/th-utilities')
-rw-r--r--dev-haskell/th-utilities/Manifest1
-rw-r--r--dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch67
-rw-r--r--dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild32
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-haskell/th-utilities/Manifest b/dev-haskell/th-utilities/Manifest
index 3b43c33fe632..532c09f9604d 100644
--- a/dev-haskell/th-utilities/Manifest
+++ b/dev-haskell/th-utilities/Manifest
@@ -1 +1,2 @@
DIST th-utilities-0.2.0.1.tar.gz 14996 BLAKE2B dc39e7f282a2b5cc4ae2442f76080e042bc0fd3fc28e29ef7e6313bd4685ed33c855c10fa9313e5b7d3c6e9fd3c8cfbe4a64d8131a156b34eabd0f437b99b850 SHA512 30cb5c09071beb1f8e029d217fefc6e58aa6eaa8a28994990d1549091fc174195b04a10e7873b1ac5f894cb4a528bf9764256ff1ad5c969493fbf5f872f1749f
+DIST th-utilities-0.2.3.0.tar.gz 15577 BLAKE2B fad72515936ba6b7876ff731c7a1e12246014e191282028fc1bd1846dc704d4d1408e82e82a394a1f58350f961c5b7b7f5b9ae0cfbf09551fc5964433d42b113 SHA512 edddde2ea3a9da44bd34cbf51d9f4ea14510eac9527f2f1a199390566e24f10ed84403f5450e47244b0cbfc4b5dc3a5c3f64ec596255f191d8bad83d9043a3ba
diff --git a/dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch b/dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch
new file mode 100644
index 000000000000..8a3795430b1f
--- /dev/null
+++ b/dev-haskell/th-utilities/files/th-utilities-0.2.3.0-ghc-8.8.patch
@@ -0,0 +1,67 @@
+commit 5e510f6a6ed24b98d143e5baeb156a8901bf3faa
+Author: Ryan Scott <ryan.gl.scott@gmail.com>
+Date: Mon Dec 10 15:12:47 2018 -0500
+
+ Allow building with template-haskell-2.15.0.0
+
+diff --git a/src/TH/ReifySimple.hs b/src/TH/ReifySimple.hs
+index d179829..70b929e 100644
+--- a/src/TH/ReifySimple.hs
++++ b/src/TH/ReifySimple.hs
+@@ -233,18 +233,24 @@ infoToDataFamily info = case info of
+ Just $ DataFamily name (map tyVarBndrName tvs) (map go insts)
+ _ -> Nothing
+ where
+-#if MIN_VERSION_template_haskell(2,11,0)
+- go (NewtypeInstD preds name params _kind con _deriving) =
++#if MIN_VERSION_template_haskell(2,15,0)
++ go (NewtypeInstD preds _ lhs _kind con _deriving)
++ | ConT name:params <- unAppsT lhs
++#elif MIN_VERSION_template_haskell(2,11,0)
++ go (NewtypeInstD preds name params _kind con _deriving)
+ #else
+- go (NewtypeInstD preds name params con _deriving) =
++ go (NewtypeInstD preds name params con _deriving)
+ #endif
+- DataInst name preds params (conToDataCons con)
+-#if MIN_VERSION_template_haskell(2,11,0)
+- go (DataInstD preds name params _kind cons _deriving) =
++ = DataInst name preds params (conToDataCons con)
++#if MIN_VERSION_template_haskell(2,15,0)
++ go (DataInstD preds _ lhs _kind cons _deriving)
++ | ConT name:params <- unAppsT lhs
++#elif MIN_VERSION_template_haskell(2,11,0)
++ go (DataInstD preds name params _kind cons _deriving)
+ #else
+- go (DataInstD preds name params cons _deriving) =
++ go (DataInstD preds name params cons _deriving)
+ #endif
+- DataInst name preds params (concatMap conToDataCons cons)
++ = DataInst name preds params (concatMap conToDataCons cons)
+ go info' = error $
+ "Unexpected instance in FamilyI in infoToDataInsts:\n" ++ pprint info'
+
+@@ -263,8 +269,23 @@ infoToTypeFamily info = case info of
+ #endif
+ _ -> Nothing
+ where
++#if MIN_VERSION_template_haskell(2,15,0)
++ goEqn _ (TySynEqn _ lhs ty)
++ | ConT name:params <- unAppsT lhs
++ = TypeInst name params ty
++ | otherwise
++ = error $ "Unexpected type family instance head: " ++ pprint lhs
++#else
+ goEqn name (TySynEqn params ty) = TypeInst name params ty
++#endif
++
++#if MIN_VERSION_template_haskell(2,15,0)
++ go (TySynInstD (TySynEqn _ lhs ty))
++ | ConT name:params <- unAppsT lhs
++ = TypeInst name params ty
++#else
+ go (TySynInstD name (TySynEqn params ty)) = TypeInst name params ty
++#endif
+ go info' = error $
+ "Unexpected instance in FamilyI in infoToTypeInsts:\n" ++ pprint info'
+
diff --git a/dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild b/dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild
new file mode 100644
index 000000000000..ce7bbd312b27
--- /dev/null
+++ b/dev-haskell/th-utilities/th-utilities-0.2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Collection of useful functions for use with Template Haskell"
+HOMEPAGE="https://github.com/fpco/th-utilities#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/primitive:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/th-orphans:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hspec
+ dev-haskell/vector )
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-8.8.patch)