summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/top
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/top')
-rw-r--r--dev-haskell/top/Manifest1
-rw-r--r--dev-haskell/top/files/top-1.7-ghc-7.10.patch66
-rw-r--r--dev-haskell/top/metadata.xml12
-rw-r--r--dev-haskell/top/top-1.7.ebuild36
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-haskell/top/Manifest b/dev-haskell/top/Manifest
new file mode 100644
index 000000000000..c374f75b6183
--- /dev/null
+++ b/dev-haskell/top/Manifest
@@ -0,0 +1 @@
+DIST Top-1.7.tar.gz 70721 SHA256 3d8da13be43fa6393d660bc0ec17c4336a93d8f0ac5808c6274149af3866717a SHA512 90d5f1042c07101c35bc1722c18667f551fa4d9034e70a4b7466ff25906899053a054f1227fed8d6d534d04fe9a1c2420585143cde44badfe98e08bf9a6225b4 WHIRLPOOL 721aad7b923963596ae83c2c5d4abff4cc5202af3af38de11354da1cbd6d4e615707be54454e363ce0b448af1e5ceb994b57884fb5a649a8dc12bf16eb1f894c
diff --git a/dev-haskell/top/files/top-1.7-ghc-7.10.patch b/dev-haskell/top/files/top-1.7-ghc-7.10.patch
new file mode 100644
index 000000000000..3acbda19e171
--- /dev/null
+++ b/dev-haskell/top/files/top-1.7-ghc-7.10.patch
@@ -0,0 +1,66 @@
+diff --git a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
+index 2cc5210..faf4c8c 100644
+--- a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
++++ b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
+@@ -1,2 +1,3 @@
++{-# LANGUAGE FlexibleContexts #-}
+ -----------------------------------------------------------------------------
+ -- | License : GPL
+diff --git a/src/Top/Monad/Select.hs b/src/Top/Monad/Select.hs
+index e5953cb..72276b4 100644
+--- a/src/Top/Monad/Select.hs
++++ b/src/Top/Monad/Select.hs
+@@ -16,4 +16,6 @@ module Top.Monad.Select
+ import Top.Util.Embedding
+ import Control.Monad.State
++import Control.Monad
++import Control.Applicative
+
+ --------------------------------------------------------
+@@ -22,4 +24,11 @@ import Control.Monad.State
+ newtype Select t m a = Select (m a)
+
++instance Monad m => Functor (Select t m) where
++ fmap = liftM
++
++instance Monad m => Applicative (Select t m) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad m => Monad (Select t m) where
+ return a = Select (return a)
+@@ -43,4 +52,11 @@ select = Select
+ data SelectFix (t :: (* -> *) -> *) (m :: * -> *) a = SelectFix (m a)
+
++instance Monad m => Functor (SelectFix t m) where
++ fmap = liftM
++
++instance Monad m => Applicative (SelectFix t m) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad m => Monad (SelectFix t m) where
+ return a = SelectFix (return a)
+diff --git a/src/Top/Monad/StateFix.hs b/src/Top/Monad/StateFix.hs
+index d77919d..bd8fb76 100644
+--- a/src/Top/Monad/StateFix.hs
++++ b/src/Top/Monad/StateFix.hs
+@@ -16,4 +16,6 @@ import Control.Monad.State
+ import Control.Monad.Identity
+ import Control.Monad.Writer
++import Control.Monad
++import Control.Applicative
+
+ type StateFix s = StateFixT s Identity
+@@ -21,4 +23,11 @@ type StateFix s = StateFixT s Identity
+ data StateFixT s m a = Fix { unFix :: StateT (s (StateFixT s m)) m a }
+
++instance Monad m => Functor (StateFixT s m) where
++ fmap = liftM
++
++instance Monad m => Applicative (StateFixT s m) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad m => Monad (StateFixT s m) where
+ return = Fix . return
diff --git a/dev-haskell/top/metadata.xml b/dev-haskell/top/metadata.xml
new file mode 100644
index 000000000000..e5eb48356de0
--- /dev/null
+++ b/dev-haskell/top/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ At its most general, Top is a framework for constructing abstract interpretations
+ which focuses on giving good feedback on why an abstract interpretation does not give
+ any useful information. In a mathematical notation this is usually made explicit by
+ returning the top element of a (complete) lattice. This is also one of the reasons
+ for the name of the project.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/top/top-1.7.ebuild b/dev-haskell/top/top-1.7.ebuild
new file mode 100644
index 000000000000..44c136c3ddf5
--- /dev/null
+++ b/dev-haskell/top/top-1.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+MY_PN="Top"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Constraint solving framework employed by the Helium Compiler"
+HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.1.0
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}