summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 08:39:21 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:56 +0000
commit7de86b4fccf96da4bd4536bd50a2a8bf20e85818 (patch)
tree160ef3fd25a12dbd3b2d0db2817a61bb277a8f19 /dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
parentdev-haskell/generics-sop: new package, a depend of dev-haskell/persistent-2.6 (diff)
downloadgentoo-7de86b4fccf96da4bd4536bd50a2a8bf20e85818.tar.gz
gentoo-7de86b4fccf96da4bd4536bd50a2a8bf20e85818.tar.bz2
gentoo-7de86b4fccf96da4bd4536bd50a2a8bf20e85818.zip
dev-haskell/uri-bytestring: new package, a depend of dev-haskell/persistent-2.6
Haskell URI parsing as ByteStrings Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild')
-rw-r--r--dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild b/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
new file mode 100644
index 000000000000..16679048fc8c
--- /dev/null
+++ b/dev-haskell/uri-bytestring/uri-bytestring-0.2.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -lib-werror
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell URI parsing as ByteStrings"
+HOMEPAGE="https://github.com/Soostone/uri-bytestring"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/blaze-builder-0.3.0.0:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/generics-sop-0.2
+ dev-haskell/hunit
+ dev-haskell/lens-simple
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances
+ dev-haskell/semigroups
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-lib-werror
+}