summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-12-11 08:19:58 +1100
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-12 22:33:19 +0000
commit22c8a1a5ba91ebd614743d0c709058df1c31b0e2 (patch)
tree6e476111c6662a5ef2b49fdf6b995a595e5c7b8e /dev-haskell/uri-bytestring
parentprofiles/arch/powerpc: unmask dev-util/gtk-doc[test] on ppc64 (diff)
downloadgentoo-22c8a1a5ba91ebd614743d0c709058df1c31b0e2.tar.gz
gentoo-22c8a1a5ba91ebd614743d0c709058df1c31b0e2.tar.bz2
gentoo-22c8a1a5ba91ebd614743d0c709058df1c31b0e2.zip
dev-haskell/uri-bytestring: bump up to 0.3.3.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/18628 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/uri-bytestring')
-rw-r--r--dev-haskell/uri-bytestring/Manifest1
-rw-r--r--dev-haskell/uri-bytestring/uri-bytestring-0.3.3.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/uri-bytestring/Manifest b/dev-haskell/uri-bytestring/Manifest
index aece035b216e..9374c7b83d0c 100644
--- a/dev-haskell/uri-bytestring/Manifest
+++ b/dev-haskell/uri-bytestring/Manifest
@@ -1 +1,2 @@
DIST uri-bytestring-0.3.2.2.tar.gz 22743 BLAKE2B fc4a5e2421350bc71c07d7353a4934150b6fd46dcacb68ec77c516113c13324663fcf1d09a5b21303bb4c9d5f9587f52a3e0779db35f4c02eb1000744ad19932 SHA512 82565afbdb00b9b4a56f8eaa3ccd42732a16a79f894c950c67cede6346af5112dcb2d226f4b11bde135cf6cfacc687799d33f660d98556d031d262ffe65cf422
+DIST uri-bytestring-0.3.3.0.tar.gz 22994 BLAKE2B 1dbe396e48773b93a3f1aae0bb84c1d525e0b5ff5831dade79c709ee215e79c1e7834296680341dc074953e249af3472e5b1504526854a28750ef5aee6acd50e SHA512 29be8a04bc95e5d86cb3f1c042e0acfec3970af7d9424c8e3218e143b2b9d783d1e7585597ba588928bd843b4d7f02dbb7f3ad862f39c60e4baa6c262faa9669
diff --git a/dev-haskell/uri-bytestring/uri-bytestring-0.3.3.0.ebuild b/dev-haskell/uri-bytestring/uri-bytestring-0.3.3.0.ebuild
new file mode 100644
index 000000000000..a0ef989d8d67
--- /dev/null
+++ b/dev-haskell/uri-bytestring/uri-bytestring-0.3.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -lib-werror
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell URI parsing as ByteStrings"
+HOMEPAGE="https://github.com/Soostone/uri-bytestring"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.13.1.0:=[profile?]
+ >=dev-haskell/blaze-builder-0.3.0.0:=[profile?]
+ >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-5:=[profile?]
+ >=dev-haskell/semigroups-0.16.2.2:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/th-lift-0.7.5:=[profile?] <dev-haskell/th-lift-0.9:=[profile?]
+ >=dev-haskell/th-lift-instances-0.1.8:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/base-compat-0.7.0
+ dev-haskell/hedgehog
+ dev-haskell/hunit
+ dev-haskell/safe
+ dev-haskell/tasty
+ dev-haskell/tasty-hedgehog
+ dev-haskell/tasty-hunit )
+"
+
+# th-lift only required for <dev-lang/ghc-8
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'th-lift >= 0.7.5 && < 0.8' 'th-lift >= 0.7.5'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-lib-werror
+}