summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-01 13:16:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-01 13:18:13 +0000
commit470b934a912300bd35918576112b990fbb3a0f30 (patch)
tree106dcbe528c4e5d701e80c2cfa285b18454158f8 /dev-haskell/uuagc/uuagc-0.9.53.1.ebuild
parentnet-misc/cmst: bump to 2020.11.01 (diff)
downloadgentoo-470b934a912300bd35918576112b990fbb3a0f30.tar.gz
gentoo-470b934a912300bd35918576112b990fbb3a0f30.tar.bz2
gentoo-470b934a912300bd35918576112b990fbb3a0f30.zip
dev-haskell/uuagc: bump up to 0.9.53.1
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/uuagc/uuagc-0.9.53.1.ebuild')
-rw-r--r--dev-haskell/uuagc/uuagc-0.9.53.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/uuagc/uuagc-0.9.53.1.ebuild b/dev-haskell/uuagc/uuagc-0.9.53.1.ebuild
new file mode 100644
index 000000000000..5421f5bd39d5
--- /dev/null
+++ b/dev-haskell/uuagc/uuagc-0.9.53.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -bootstrap_external
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Attribute Grammar System of Universiteit Utrecht"
+HOMEPAGE="http://www.cs.uu.nl/wiki/HUT/WebHome"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="loag"
+
+RDEPEND=">=dev-haskell/haskell-src-exts-1.11.1:=[profile?]
+ >=dev-haskell/mtl-1.1.1.1:=[profile?]
+ >=dev-haskell/uuagc-cabal-1.0.2.0:=[profile?]
+ >=dev-haskell/uulib-0.9.14:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ loag? ( dev-haskell/minisat:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap_external \
+ $(cabal_flag loag with-loag)
+}