summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-23 23:43:20 +0100
committerSam James <sam@gentoo.org>2022-07-23 23:47:39 +0100
commitae3adc8ffe771902ccac6fdf423ae8c522e068af (patch)
tree7d3d7a5cfb5784f8223b2e64e63e0660bd6a146d /dev-haskell/uuid
parentprofiles: un-last-rite dev-haskell/markdown-unlit (diff)
downloadgentoo-ae3adc8ffe771902ccac6fdf423ae8c522e068af.tar.gz
gentoo-ae3adc8ffe771902ccac6fdf423ae8c522e068af.tar.bz2
gentoo-ae3adc8ffe771902ccac6fdf423ae8c522e068af.zip
dev-haskell/uuid: add 1.3.15 (sync w/ ::haskell)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/uuid')
-rw-r--r--dev-haskell/uuid/Manifest1
-rw-r--r--dev-haskell/uuid/metadata.xml5
-rw-r--r--dev-haskell/uuid/uuid-1.3.15.ebuild36
3 files changed, 37 insertions, 5 deletions
diff --git a/dev-haskell/uuid/Manifest b/dev-haskell/uuid/Manifest
index 61e13c8f4bc8..266722b04311 100644
--- a/dev-haskell/uuid/Manifest
+++ b/dev-haskell/uuid/Manifest
@@ -1 +1,2 @@
DIST uuid-1.3.13.tar.gz 8926 BLAKE2B d7b4850eb921467677534d33475dccb90b2e74a4f73137eb8e9a45573a337d4152b19f052dea584bb0b6ab862dcdf764106c4e35efa1e8ae3ecec41becc75a4e SHA512 e888e6350a32c6496b0b57384797925c78ab1c4dc674d296972981fa81338b4705d21a96960a63771aa5b9a785efd507ecaad195767dba7847fcab5ca7f3f923
+DIST uuid-1.3.15.tar.gz 8815 BLAKE2B fec665690dc6fe05e9b7083700ca5ba2723d9bbd7cdc7f8770359d26b9b4b32572e15b686bc4589a3bed2cd25caa02cbea96270ea2e373941451aa6f315df401 SHA512 acb5c17b809bee5ce2f1591f3382a7c3a57e9d20a47d8f47be717b0e7fbfd803603810ebaaf88597bcf98dff698f4807dc7d8122a0d7d36785a47e0e065fb59e
diff --git a/dev-haskell/uuid/metadata.xml b/dev-haskell/uuid/metadata.xml
index 69b916ffe552..8bd9ed7a20bf 100644
--- a/dev-haskell/uuid/metadata.xml
+++ b/dev-haskell/uuid/metadata.xml
@@ -5,11 +5,6 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library is useful for creating, comparing, parsing and
- printing Universally Unique Identifiers.
- See &lt;https://en.wikipedia.org/wiki/UUID&gt; for the general idea.
- </longdescription>
<upstream>
<remote-id type="github">aslatter/uuid</remote-id>
</upstream>
diff --git a/dev-haskell/uuid/uuid-1.3.15.ebuild b/dev-haskell/uuid/uuid-1.3.15.ebuild
new file mode 100644
index 000000000000..2b511217050a
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite has too new tasty
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/haskell-hvr/uuid"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12:=[profile?]
+ >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12:=[profile?]
+ >=dev-haskell/entropy-0.3.7:=[profile?] <dev-haskell/entropy-0.5:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.5:=[profile?] <dev-haskell/uuid-types-1.0.6:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
+# >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+# >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+# >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+# "