summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:27:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit1bfb002e2acaa4fc5fd916cdc1d407e4f2bdb2f9 (patch)
tree05a736f8fee7e7b5a4d4374701ae9dd5fa183632 /dev-haskell/vault/vault-0.3.0.5.ebuild
parentdev-haskell/uulib: bump up to 0.9.22 (diff)
downloadgentoo-1bfb002e2acaa4fc5fd916cdc1d407e4f2bdb2f9.tar.gz
gentoo-1bfb002e2acaa4fc5fd916cdc1d407e4f2bdb2f9.tar.bz2
gentoo-1bfb002e2acaa4fc5fd916cdc1d407e4f2bdb2f9.zip
dev-haskell/vault: bump up to 0.3.0.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/vault/vault-0.3.0.5.ebuild')
-rw-r--r--dev-haskell/vault/vault-0.3.0.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/vault/vault-0.3.0.5.ebuild b/dev-haskell/vault/vault-0.3.0.5.ebuild
new file mode 100644
index 000000000000..906fe9a99a14
--- /dev/null
+++ b/dev-haskell/vault/vault-0.3.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: +useghc
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="a persistent store for values of arbitrary types"
+HOMEPAGE="https://github.com/HeinrichApfelmus/vault"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.5:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=useghc
+}