summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:28:51 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commiteb95eeeffbcf47623ece3fb961d08e963734b071 (patch)
tree1ad6420d303b5c3dae5189a5a0de370703226b56 /dev-haskell/void/void-0.7.1.ebuild
parentdev-haskell/vector-th-unbox: bump up to 0.2.1.3 (diff)
downloadgentoo-eb95eeeffbcf47623ece3fb961d08e963734b071.tar.gz
gentoo-eb95eeeffbcf47623ece3fb961d08e963734b071.tar.bz2
gentoo-eb95eeeffbcf47623ece3fb961d08e963734b071.zip
dev-haskell/void: bump up to 0.7.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/void/void-0.7.1.ebuild')
-rw-r--r--dev-haskell/void/void-0.7.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/void/void-0.7.1.ebuild b/dev-haskell/void/void-0.7.1.ebuild
new file mode 100644
index 000000000000..3f59c64e765b
--- /dev/null
+++ b/dev-haskell/void/void-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Haskell 98 logically uninhabited data type"
+HOMEPAGE="https://github.com/ekmett/void"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="safe"
+
+RDEPEND=">=dev-haskell/hashable-1.1:=[profile?]
+ >=dev-haskell/semigroups-0.8.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag safe safe)
+}