summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-12-15 06:38:12 +1100
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-14 23:53:37 +0000
commit008793c783d665a57e79789e38073cc0ac4d9f30 (patch)
tree40f8e6773b398890087c1a26723d6cf4cd39b233 /dev-haskell/yesod-core
parentdev-haskell/wai-extra: bump up to 3.1.4.1 (diff)
downloadgentoo-008793c783d665a57e79789e38073cc0ac4d9f30.tar.gz
gentoo-008793c783d665a57e79789e38073cc0ac4d9f30.tar.bz2
gentoo-008793c783d665a57e79789e38073cc0ac4d9f30.zip
dev-haskell/yesod-core: bump up to 1.6.18.8
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/yesod-core')
-rw-r--r--dev-haskell/yesod-core/Manifest1
-rw-r--r--dev-haskell/yesod-core/yesod-core-1.6.18.8.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/yesod-core/Manifest b/dev-haskell/yesod-core/Manifest
index 7a6daa51ab59..b8c90309fb9a 100644
--- a/dev-haskell/yesod-core/Manifest
+++ b/dev-haskell/yesod-core/Manifest
@@ -1 +1,2 @@
DIST yesod-core-1.6.18.7.tar.gz 100141 BLAKE2B 0d00fffcc4371868f02ec5ec1fe4f5af15369f62b7bf88562e8c092b3988824cbbe26defd574f2514d23fca983f81cc951b75f564213f568d244069e352cc198 SHA512 fde155df74588d2eb9824e0f423b666228a1b681a83c4f30e194c8816667cd6e4fefb7cddcd66f6ff2ca745ad3ef8daee439a133b017d8583167b54a698a12a1
+DIST yesod-core-1.6.18.8.tar.gz 100016 BLAKE2B 117535cc875be850011b357ebf3bb89e6d854870cefe26e20001e70b93247d85a3bd190e2f889626819f8bc80211b2c64b5d8dac7e9606229ed07c03d8926c2e SHA512 1774281bf8de190995360bcf461adc46b65bac5fa2200aada0b511f73b3bc7bab8365fa4737b4de4723481f7b76c0cb440d68b118c15c46e3d455ea9126bffa7
diff --git a/dev-haskell/yesod-core/yesod-core-1.6.18.8.ebuild b/dev-haskell/yesod-core/yesod-core-1.6.18.8.ebuild
new file mode 100644
index 000000000000..8398bc10dcff
--- /dev/null
+++ b/dev-haskell/yesod-core/yesod-core-1.6.18.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="https://www.yesodweb.com/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # requires network
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ dev-haskell/auto-update:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.7.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/clientsession-0.9.1:=[profile?] <dev-haskell/clientsession-0.10:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ >=dev-haskell/cookie-0.4.3:=[profile?] <dev-haskell/cookie-0.5:=[profile?]
+ >=dev-haskell/fast-logger-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/monad-logger-0.3.10:=[profile?] <dev-haskell/monad-logger-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/path-pieces-0.1.2:=[profile?] <dev-haskell/path-pieces-0.3:=[profile?]
+ >=dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/random-1.0.0.2:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/shakespeare-2.0:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?]
+ >=dev-haskell/wai-extra-3.0.7:=[profile?]
+ >=dev-haskell/wai-logger-0.2:=[profile?]
+ >=dev-haskell/warp-3.0.2:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-lang/ghc-8.2.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0.0.2
+ test? ( dev-haskell/async
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hspec-expectations
+ dev-haskell/hunit
+ dev-haskell/network
+ dev-haskell/streaming-commons )
+"