summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 20:52:47 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:56:57 +0000
commitc3d0ba3b0756218a6ac5fa0a11018b43ff21ac73 (patch)
tree1bbe4f6fda002dbf72818feb4ec72c796181d7d4 /dev-haskell/yesod-test/yesod-test-1.5.4.1.ebuild
parentdev-haskell/yesod-static: bump up to 1.5.1.1 (diff)
downloadgentoo-c3d0ba3b0756218a6ac5fa0a11018b43ff21ac73.tar.gz
gentoo-c3d0ba3b0756218a6ac5fa0a11018b43ff21ac73.tar.bz2
gentoo-c3d0ba3b0756218a6ac5fa0a11018b43ff21ac73.zip
dev-haskell/yesod-test: bump up to 1.5.4.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/yesod-test/yesod-test-1.5.4.1.ebuild')
-rw-r--r--dev-haskell/yesod-test/yesod-test-1.5.4.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/yesod-test/yesod-test-1.5.4.1.ebuild b/dev-haskell/yesod-test/yesod-test-1.5.4.1.ebuild
new file mode 100644
index 000000000000..8e3405faf167
--- /dev/null
+++ b/dev-haskell/yesod-test/yesod-test-1.5.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="integration testing for WAI/Yesod Applications"
+HOMEPAGE="http://www.yesodweb.com"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ >=dev-haskell/hspec-core-2:=[profile?] <dev-haskell/hspec-core-3:=[profile?]
+ >=dev-haskell/html-conduit-0.1:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-2.2:=[profile?]
+ >=dev-haskell/persistent-1.0:=[profile?]
+ >=dev-haskell/pretty-show-1.6:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?]
+ dev-haskell/wai-extra:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?]
+ >=dev-haskell/xml-types-0.3:=[profile?]
+ >=dev-haskell/yesod-core-1.4.14:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hspec
+ dev-haskell/lifted-base
+ dev-haskell/yesod-form )
+"