summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:04:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit0b2ab6ad9fb339f9a383fc1e0a1be3a24bfeb41b (patch)
treedf0f622ab2f6dae0739976073b3875e25d6697e1 /dev-haskell
parentdev-haskell/resourcet: bump up to 1.1.7 (diff)
downloadgentoo-0b2ab6ad9fb339f9a383fc1e0a1be3a24bfeb41b.tar.gz
gentoo-0b2ab6ad9fb339f9a383fc1e0a1be3a24bfeb41b.tar.bz2
gentoo-0b2ab6ad9fb339f9a383fc1e0a1be3a24bfeb41b.zip
dev-haskell/sandi: bump up to 0.3.6
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/sandi/Manifest1
-rw-r--r--dev-haskell/sandi/sandi-0.3.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/sandi/Manifest b/dev-haskell/sandi/Manifest
index bbc45c89ce2c..a914c9fc5195 100644
--- a/dev-haskell/sandi/Manifest
+++ b/dev-haskell/sandi/Manifest
@@ -1 +1,2 @@
DIST sandi-0.3.5.tar.gz 18700 SHA256 856ed995bad4183a69f65c70a78c4be37cf614c906097ea126bae75ce08daea5 SHA512 0ba8f1cbb10097283a58a133c3e119335efd326f9a27a9178b424c5d0fac31a28dcd2167b17a7d8a934f638a1d98c41f4592184124387c37e37961db43f3b020 WHIRLPOOL e953262ea2e4a0d0074bb420a7a57804ec7e194b17205c3f07121171df98459fec0d6ff0a95b959c61b4981febdf54002231ad42a6b4cea6ff593cf675558c6f
+DIST sandi-0.3.6.tar.gz 18463 SHA256 fafcb3501b8a17238de44239ef62c3051f9a33010424ef91dd76057257bf2284 SHA512 8a730f63e72fb648e2ae478a3785ab364b437a319735acda80558639cc0a43027639ff01dd2b630277348ebc31a4a5fe30ede8f4208229c1c8810f78d350bbf2 WHIRLPOOL 3eb72f69eb0e72380b91c5e12353bb1c00e6572c151a5e40a770c1b51278ed4ab27b89136f04db9b4a7b48bf9da69fa4356f800e1fa45061eaf9da36c688dad5
diff --git a/dev-haskell/sandi/sandi-0.3.6.ebuild b/dev-haskell/sandi/sandi-0.3.6.ebuild
new file mode 100644
index 000000000000..c1c26058a660
--- /dev/null
+++ b/dev-haskell/sandi/sandi-0.3.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://hackage.haskell.org/package/sandi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+with-conduit"
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+ with-conduit? ( >=dev-haskell/conduit-1.2:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/exceptions-0.6:=[profile?] <dev-haskell/exceptions-0.9:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hunit
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ dev-haskell/tasty-th )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag with-conduit with-conduit)
+}