summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-23 23:46:51 +0100
committerSam James <sam@gentoo.org>2022-07-23 23:47:41 +0100
commit263a6ce5e1c81d6ee9696b4a760a490f4fc0fc81 (patch)
treeb9505f13dd8dcf093196fee0eb6e5bd4f210f218 /dev-haskell
parentdev-haskell/semigroups: refresh metadata (diff)
downloadgentoo-263a6ce5e1c81d6ee9696b4a760a490f4fc0fc81.tar.gz
gentoo-263a6ce5e1c81d6ee9696b4a760a490f4fc0fc81.tar.bz2
gentoo-263a6ce5e1c81d6ee9696b4a760a490f4fc0fc81.zip
dev-haskell/aws: fixup deps (sync w/ ::haskell)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/aws/Manifest1
-rw-r--r--dev-haskell/aws/aws-0.22-r4.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-haskell/aws/Manifest b/dev-haskell/aws/Manifest
index f7b3eacc87cf..08b58c20e882 100644
--- a/dev-haskell/aws/Manifest
+++ b/dev-haskell/aws/Manifest
@@ -1 +1,2 @@
+DIST aws-0.22-r4.cabal 15515 BLAKE2B 7936d1ba22ef5d60baf8804d5d77b5202f6fcef31b63cba9c06ffe5f66aae8d584c3877887e408033efe36bc9cf04c738c545ca61e9eceeaee61bb168ac1e062 SHA512 a6a1d639cedf6929f60cf4b4187fbefb72f7024cbdaa3c3d383acc933be1f03b139c4b58a34afaf7ecdc355ee507f4411e9953f98127850d4978a6ba859f4e8e
DIST aws-0.22.tar.gz 106122 BLAKE2B b4ff46e2742d53323c80952c303a4605d13600fd60085a2e0501af2fc0a74f0c2769c6bf0692710bbfd972c474b9cab26fd97e9126fdcfb3eaff90afbab1d9ae SHA512 e7ff376c47a7ca7a65c8f10f19e591d4a4b4d2cfa333b4727f88f0b170d7acb0aff402617f2d617c522fe5d16ce92b249a23f1fb0a8bfe5bbefaef2931b786bd
diff --git a/dev-haskell/aws/aws-0.22-r4.ebuild b/dev-haskell/aws/aws-0.22-r4.ebuild
new file mode 100644
index 000000000000..78feeaf7c7df
--- /dev/null
+++ b/dev-haskell/aws/aws-0.22-r4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: +networkbsd
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite requires deps porting
+inherit haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="https://github.com/aristidb/aws"
+HACKAGE_REV="3"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT=test # requires aws account
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/conduit-extra-1.3:=[profile?] <dev-haskell/conduit-extra-1.4:=[profile?]
+ >=dev-haskell/cryptonite-0.11:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
+ >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/http-client-tls-0.3:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/http-conduit-2.3:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-1.0:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.8:=[profile?] <dev-haskell/xml-conduit-2.0:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ examples? ( >=dev-haskell/errors-2.0:=[profile?] )
+ >=dev-haskell/network-3:=[profile?] <dev-haskell/network-4:=[profile?]
+ >=dev-haskell/network-bsd-2.8:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3"
+# test? ( >=dev-haskell/aeson-0.7
+# >=dev-haskell/http-client-0.3 <dev-haskell/http-client-0.8
+# >=dev-haskell/lifted-base-0.2
+# >=dev-haskell/mtl-2.1
+# >=dev-haskell/quickcheck-2.7
+# >=dev-haskell/quickcheck-instances-0.3
+# >=dev-haskell/tasty-0.8
+# >=dev-haskell/tasty-hunit-0.8
+# >=dev-haskell/tasty-quickcheck-0.8
+# >=dev-haskell/text-1.1
+# >=dev-haskell/transformers-base-0.4
+# !examples? ( >=dev-haskell/errors-2.0 ) )
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ --flag=networkbsd
+}