summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:57 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:26 +0100
commit4c539e417a1d99e51dac3c8c57aee724184b9981 (patch)
tree82b3d18e7675ee4a5b9b50b130400eb4e0703e63 /dev-haskell
parentdev-haskell/recv: new package, add 0.1.0 (diff)
downloadgentoo-4c539e417a1d99e51dac3c8c57aee724184b9981.tar.gz
gentoo-4c539e417a1d99e51dac3c8c57aee724184b9981.tar.bz2
gentoo-4c539e417a1d99e51dac3c8c57aee724184b9981.zip
dev-haskell/warp: add 3.3.28
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/warp/Manifest1
-rw-r--r--dev-haskell/warp/metadata.xml1
-rw-r--r--dev-haskell/warp/warp-3.3.28.ebuild54
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/warp/Manifest b/dev-haskell/warp/Manifest
index a94001ab80a3..95d18997e935 100644
--- a/dev-haskell/warp/Manifest
+++ b/dev-haskell/warp/Manifest
@@ -1 +1,2 @@
DIST warp-3.3.21.tar.gz 66529 BLAKE2B e8de94a4695c42a7620c1afa1a38225f6c26fc454235e941e34b65929a733e160781d895335d0ab48c4d7db25aa650d50e1d84a3ef83daf62b22f409c2045d48 SHA512 7f181669d9f10f88d14f8f1dc3acb6c08f41c8f4565f371f7fe4b89b3fde411a0190e50f003b07a239ba25ea71dbafaa16cb9e77effbe574bec929ea29646f37
+DIST warp-3.3.28.tar.gz 65625 BLAKE2B b054d03b66cdcf67a990dd9c1f8ba822e416da3f7e5d6dfa9afbf9ecc8f154e5bba2013beadf616174a629c90c1203f3205d88763dfa6644f7085f1b3c48f587 SHA512 5f3a73f611342545d010ba770614b7012c31a335fe4d209a4f7f3d466b440901a58b0f3f477da10b95bb739dbd30afffa1ced66828039159844eb476c845648e
diff --git a/dev-haskell/warp/metadata.xml b/dev-haskell/warp/metadata.xml
index f9a038094525..153f3ad7acc9 100644
--- a/dev-haskell/warp/metadata.xml
+++ b/dev-haskell/warp/metadata.xml
@@ -10,6 +10,7 @@
<flag name="x509">Adds a dependency on the x509 library to enable getting TLS client certificates.</flag>
</use>
<upstream>
+ <remote-id type="hackage">warp</remote-id>
<remote-id type="github">yesodweb/wai</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/warp/warp-3.3.28.ebuild b/dev-haskell/warp/warp-3.3.28.ebuild
new file mode 100644
index 000000000000..4e2a9921d4e2
--- /dev/null
+++ b/dev-haskell/warp/warp-3.3.28.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +allow-sendfilefd,-network-bytestring,warp-debug:debug
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A fast, light-weight web server for WAI applications"
+HOMEPAGE="https://github.com/yesodweb/wai"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="debug +x509"
+
+RDEPEND=">=dev-haskell/auto-update-0.1.3:=[profile?] <dev-haskell/auto-update-0.2:=[profile?]
+ <dev-haskell/bsb-http-chunked-0.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.12:=[profile?]
+ >=dev-haskell/http2-3.0:=[profile?] <dev-haskell/http2-5:=[profile?]
+ >=dev-haskell/iproute-1.3.1:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/recv-0.1.0:=[profile?] <dev-haskell/recv-0.2.0:=[profile?]
+ >=dev-haskell/simple-sendfile-0.2.7:=[profile?] <dev-haskell/simple-sendfile-0.3:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.10:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/time-manager:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ >=dev-haskell/vault-0.3:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ x509? ( dev-haskell/crypton-x509:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/http-client
+ dev-haskell/quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=allow-sendfilefd \
+ --flag=-network-bytestring \
+ $(cabal_flag debug warp-debug) \
+ $(cabal_flag x509 x509)
+}