summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-04 07:57:22 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-04 07:57:37 +0100
commit4fd66f2fe4942584c057c1e028d909d8f15f024b (patch)
treeb850a5a960c1b69368442ca113f60222c8dac2be /dev-haskell
parentdev-haskell/uri-bytestring-aeson: new package, a depend of hoauth-1.8.9 (diff)
downloadgentoo-4fd66f2fe4942584c057c1e028d909d8f15f024b.tar.gz
gentoo-4fd66f2fe4942584c057c1e028d909d8f15f024b.tar.bz2
gentoo-4fd66f2fe4942584c057c1e028d909d8f15f024b.zip
dev-haskell/hoauth2: bump to 1.8.9
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hoauth2/Manifest1
-rw-r--r--dev-haskell/hoauth2/hoauth2-1.8.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/hoauth2/Manifest b/dev-haskell/hoauth2/Manifest
index 4bb4daf0afc2..c6128d2f3fae 100644
--- a/dev-haskell/hoauth2/Manifest
+++ b/dev-haskell/hoauth2/Manifest
@@ -1,2 +1,3 @@
DIST hoauth2-0.4.8.tar.gz 8599 BLAKE2B 9cfaf6bf26937a5b3e9e03489843cd9173aea20d4360bfbbdbb9e083f7ec0c2191f19b6c8b86f07d5216c8fa064558183203d0f3d05e8390afb2a7d3a2f82455 SHA512 b2abf00d0ae7d15911f4a1e17d90d6f0b3931800bc66d77545c566fc64de527cfc86121b57a4ff4187a4a0aa81aea2e150412bf928fdec8e506ab24f9e1bea29
DIST hoauth2-0.5.7.tar.gz 12245 BLAKE2B 641c30f90c4420c40e0c73397d5a830c1b9f24095bf31108531303fbfc8d56e4a614a09c2e2fdc11204521d2299faf2c15fd8dc6a0541627c0804ce485cd8bc6 SHA512 218c5cb722861af099efa1cf66025b3fbdaba3574b19fbe39db5bb3ca8431c8436329b9bf9cd7a642227e2bca964843bba6b94cb70d5020321b3f743cc020569
+DIST hoauth2-1.8.9.tar.gz 16766 BLAKE2B ee95c10f571815683989f05e64539012b04009f6ee967d62ab6ed40c09d4a7f555f144452eb1a137f9a5f9d79077d8eac042c20bd9199356b8092eaaa46f1475 SHA512 c77f66f54310dea587de5d0f5a37c4d113881705a80b525a9180c94a3eae9d9d8a691ec3759bfd7681f467a633a2692df2e4ef69b6919b5147ee5546c9b49aa4
diff --git a/dev-haskell/hoauth2/hoauth2-1.8.9.ebuild b/dev-haskell/hoauth2/hoauth2-1.8.9.ebuild
new file mode 100644
index 000000000000..0d8f917b5795
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-1.8.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -test
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication client"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.3.0.0:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
+ >=dev-haskell/exceptions-0.8.3:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
+ >=dev-haskell/http-types-0.11:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
+ >=dev-haskell/microlens-0.4.0:=[profile?] <dev-haskell/microlens-0.5:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?]
+ >=dev-haskell/uri-bytestring-0.2.3.1:=[profile?] <dev-haskell/uri-bytestring-0.4:=[profile?]
+ >=dev-haskell/uri-bytestring-aeson-0.1:=[profile?] <dev-haskell/uri-bytestring-aeson-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test
+}