summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:09 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:29 +0100
commit6188355cf0af19cb96fbab3f3cb8aaacf200af47 (patch)
treedbaffbb3090f1f5d94cfdd7f81d2067a7091c49f /dev-haskell
parentdev-haskell/xml-hamlet: add 0.5.0.2 (diff)
downloadgentoo-6188355cf0af19cb96fbab3f3cb8aaacf200af47.tar.gz
gentoo-6188355cf0af19cb96fbab3f3cb8aaacf200af47.tar.bz2
gentoo-6188355cf0af19cb96fbab3f3cb8aaacf200af47.zip
dev-haskell/xss-sanitize: add 0.3.7.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/xss-sanitize/Manifest1
-rw-r--r--dev-haskell/xss-sanitize/metadata.xml4
-rw-r--r--dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild33
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-haskell/xss-sanitize/Manifest b/dev-haskell/xss-sanitize/Manifest
index da3250d11aa4..ca500737c927 100644
--- a/dev-haskell/xss-sanitize/Manifest
+++ b/dev-haskell/xss-sanitize/Manifest
@@ -1 +1,2 @@
DIST xss-sanitize-0.3.6.tar.gz 11655 BLAKE2B b1d438a6bfa587aa9eb62031fb2c1c53cc48bbadc26b6f64ce717d20d5ab9e282ed657ce5109e0501de393a8609ba99fb9e73966220dc358b222f69301ab5661 SHA512 8d038d807b7fa01a65f4b73d135c87ab75385f4c91ce174b332cd5fd1dc1ebdec26b0c5713cf3f68c27351e19e099815d1b530af3ecb7e4c45e71fec4ae12b4c
+DIST xss-sanitize-0.3.7.2.tar.gz 12002 BLAKE2B 960c3bcbdb44eee95c02e9f52b416fa283712acd1d400f1add5d9649d445e1283cc8ab73ffd797b1a331db7bbc562dbc0443db7e930fd43ad2799899db464f67 SHA512 affd74f2df2e31eb12348fd51890028cce76c3c5f905e5d10979a98dd3a325f522758b3bd7cdcdc5ab08c212468eac3326c40f62ac71e92cf4029c9c94d6dd2a
diff --git a/dev-haskell/xss-sanitize/metadata.xml b/dev-haskell/xss-sanitize/metadata.xml
index 7adbbfcd9222..cd6528164118 100644
--- a/dev-haskell/xss-sanitize/metadata.xml
+++ b/dev-haskell/xss-sanitize/metadata.xml
@@ -5,10 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- run untrusted HTML through Text.HTML.SanitizeXSS.sanitizeXSS to prevent XSS attacks. see README.md &lt;https://github.com/yesodweb/haskell-xss-sanitize&gt; for more details
- </longdescription>
<upstream>
+ <remote-id type="hackage">xss-sanitize</remote-id>
<remote-id type="github">yesodweb/haskell-xss-sanitize</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild b/dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild
new file mode 100644
index 000000000000..b099d090cb66
--- /dev/null
+++ b/dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
+HOMEPAGE="https://github.com/yesodweb/haskell-xss-sanitize#readme"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
+ >=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ >=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/hunit-1.2
+ )
+"