summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:14 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:30 +0100
commit724e25992c6b173d549faa88af1551bc653cd779 (patch)
treeb48641a2e96eb9570aea1343b8230f6607508880 /dev-haskell
parentdev-haskell/yesod-form: add 1.7.4 (diff)
downloadgentoo-724e25992c6b173d549faa88af1551bc653cd779.tar.gz
gentoo-724e25992c6b173d549faa88af1551bc653cd779.tar.bz2
gentoo-724e25992c6b173d549faa88af1551bc653cd779.zip
dev-haskell/yesod-test: add 1.6.14
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/yesod-test/Manifest1
-rw-r--r--dev-haskell/yesod-test/yesod-test-1.6.14.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/yesod-test/Manifest b/dev-haskell/yesod-test/Manifest
index fcd6d48b93f8..f6bd5a81d064 100644
--- a/dev-haskell/yesod-test/Manifest
+++ b/dev-haskell/yesod-test/Manifest
@@ -1 +1,2 @@
DIST yesod-test-1.6.12.tar.gz 27738 BLAKE2B 53cc4dc136b4d08c932812f2bd0b7f46ccc4acc3b0b0a2020386092006010859d3c0b14d9e4b36e91ae46617941d008d1795d652ccd1068437e537de83a4e4c3 SHA512 777d112d8c5ae77d667da2b8d1ed91a1cf751850d5b3678e787e7123aca8666d0a4b6d6161b7109491012d56c160603d62563b881a136ccc76a1edd006c423d6
+DIST yesod-test-1.6.14.tar.gz 28627 BLAKE2B c27e2825f07be19be645d1d1085e89e89988b21bdb7f9ef90fcebaae82626dad410a96365435223ac2cd25d156f3cdbe1c35f61b378023aa4175152c68802a3e SHA512 63c3f168f70e8ef1a9ba409a3052bab6c21aed8cb38df3c3ae68d553f74f1ec213db2120d9f985363d167726c161a24bc4a4e4ebd21a5f00b11259e931c0321e
diff --git a/dev-haskell/yesod-test/yesod-test-1.6.14.ebuild b/dev-haskell/yesod-test/yesod-test-1.6.14.ebuild
new file mode 100644
index 000000000000..b7c7cb5f1ac7
--- /dev/null
+++ b/dev-haskell/yesod-test/yesod-test-1.6.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="integration testing for WAI/Yesod Applications"
+HOMEPAGE="https://www.yesodweb.com"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/blaze-markup:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ >=dev-haskell/hspec-core-2:=[profile?] <dev-haskell/hspec-core-3:=[profile?]
+ >=dev-haskell/html-conduit-0.1:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/network-2.2:=[profile?]
+ >=dev-haskell/pretty-show-1.6:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?]
+ dev-haskell/wai-extra:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?]
+ >=dev-haskell/xml-types-0.3:=[profile?]
+ >=dev-haskell/yesod-core-1.6.17:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hspec
+ dev-haskell/unliftio
+ dev-haskell/unliftio-core
+ >=dev-haskell/yesod-form-1.6 )
+"