summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-25 15:59:08 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-25 15:59:08 +0100
commita083c9cf5780da826c9502a8222ac2ccca517cc9 (patch)
treeefd0742cd8ca7064a6e128745682b04c16d2dc91 /dev-haskell
parentdev-haskell/project-template: drop old (diff)
downloadgentoo-a083c9cf5780da826c9502a8222ac2ccca517cc9.tar.gz
gentoo-a083c9cf5780da826c9502a8222ac2ccca517cc9.tar.bz2
gentoo-a083c9cf5780da826c9502a8222ac2ccca517cc9.zip
dev-haskell/nonce: allow latest base64-bytestring
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/nonce/nonce-1.0.7-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/nonce/nonce-1.0.7-r1.ebuild b/dev-haskell/nonce/nonce-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..4dc5e78c00d9
--- /dev/null
+++ b/dev-haskell/nonce/nonce-1.0.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generate cryptographic nonces"
+HOMEPAGE="https://github.com/prowdsponsor/nonce"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.3:=[profile?]
+ >=dev-haskell/entropy-0.3.7:=[profile?]
+ >=dev-haskell/text-0.9:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base64-bytestring == 1.0.*' 'base64-bytestring >= 1.0 && < 1.3' \
+ 'entropy >= 0.3.7 && < 0.4.2' 'entropy >= 0.3.7'
+}