summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:25:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commitc4581be7d7f9ebde325587048ac8664247d5c893 (patch)
tree8b7ed7e401a8b00a72505d3b6f5cf7c326ae4c75 /dev-haskell
parentdev-haskell/utf8-string: bump up to 1.0.1.1 (diff)
downloadgentoo-c4581be7d7f9ebde325587048ac8664247d5c893.tar.gz
gentoo-c4581be7d7f9ebde325587048ac8664247d5c893.tar.bz2
gentoo-c4581be7d7f9ebde325587048ac8664247d5c893.zip
dev-haskell/uuid: allow hunit-1.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/uuid/uuid-1.3.11-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/uuid/uuid-1.3.11-r2.ebuild b/dev-haskell/uuid/uuid-1.3.11-r2.ebuild
new file mode 100644
index 000000000000..61d94d603855
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.11-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/aslatter/uuid"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/cryptohash-0.7:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.9
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'HUnit >=1.2 && < 1.3' 'HUnit >=1.2' \
+ 'tasty == 0.10.*' 'tasty >= 0.10'
+}