summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:17 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:31 +0100
commitc5648ef18740925e68eaeb6b82c9d037918a7b41 (patch)
treee70171dd9b798bcee5a192128eee41b07fa02218 /dev-haskell
parentdev-haskell/zip-archive: add 0.4.3 (diff)
downloadgentoo-c5648ef18740925e68eaeb6b82c9d037918a7b41.tar.gz
gentoo-c5648ef18740925e68eaeb6b82c9d037918a7b41.tar.bz2
gentoo-c5648ef18740925e68eaeb6b82c9d037918a7b41.zip
dev-haskell/zlib: add 0.6.3.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/zlib/Manifest2
-rw-r--r--dev-haskell/zlib/metadata.xml19
-rw-r--r--dev-haskell/zlib/zlib-0.6.3.0.ebuild38
3 files changed, 45 insertions, 14 deletions
diff --git a/dev-haskell/zlib/Manifest b/dev-haskell/zlib/Manifest
index b2128f215356..e6b18aa36be8 100644
--- a/dev-haskell/zlib/Manifest
+++ b/dev-haskell/zlib/Manifest
@@ -1 +1,3 @@
DIST zlib-0.6.2.3.tar.gz 149186 BLAKE2B 5665c6a076c0efdb6074ca72e3723ddeb4a7d851abf06450ccb8a4ee6179c3e45be63c3c620d02787b088a6c18723ba2d5a77c525d59dc4ab9bbe1770e79517b SHA512 535fc711af639967c032791c6a0c09680ac186c706e02a28cfabd9b2dcddc84a6ee5f6007e2ed67c1dc19dd6d561cb821d8840dba7386b63cc002418c4d5040a
+DIST zlib-0.6.3.0-rev2.cabal 5367 BLAKE2B 4fb30c7af39286710ee5925f6e211c69c90b75f17c99f527e62ca4f9b0271544e22cdb4973f35c45524f81ca4401623effcb85830ada0aa5d11880db6d4742d6 SHA512 9f2851974abc0da417afdb914f4ce3d72c5945d23a39685174f40f2224ba5001a94ae9761cf44b2961a8fa135f28c689bcf913267a2b086e73fa353e9dc22672
+DIST zlib-0.6.3.0.tar.gz 369595 BLAKE2B 3a3ecb4ef2cce3332be22a1137b89c3ff27a600326fbc4c53610a588bcfe79f2c3b6916ad68705b7d397c0cc53aaf958a19eccd39edfb66e07b3cfae701d8890 SHA512 95daae13c5d5458fd7c610ce4cc686dc7af477364c4dcf3d31abede84f6e4b4e70ea255f7ded586d46d9bb6298d19c93b8856eec16c6002265ed076e52bf9a21
diff --git a/dev-haskell/zlib/metadata.xml b/dev-haskell/zlib/metadata.xml
index 7db31073ae41..4c34a34bede0 100644
--- a/dev-haskell/zlib/metadata.xml
+++ b/dev-haskell/zlib/metadata.xml
@@ -6,19 +6,10 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="bundled-c-zlib">Use the bundled zlib C sources. Requires pkg-config to be False. For windows, this is the default.</flag>
- <flag name="non-blocking-ffi">The (de)compression calls can sometimes take a long time, which prevents other Haskell threads running. Enabling this flag avoids this unfairness, but with greater overall cost.</flag>
+ <flag name="bundled-c-zlib">Use the bundled zlib C sources. Requires pkg-config to be False.
+For windows, this is the default.</flag>
+ <flag name="non-blocking-ffi">The (de)compression calls can sometimes take a long time, which
+prevents other Haskell threads running. Enabling this flag
+avoids this unfairness, but with greater overall cost.</flag>
</use>
- <longdescription>
- This package provides a pure interface for compressing and
- decompressing streams of data represented as lazy
- 'ByteString's. It uses the
- &lt;https://en.wikipedia.org/wiki/Zlib zlib C library&gt;
- so it has high performance. It supports the \"zlib\",
- \"gzip\" and \"raw\" compression formats.
-
- It provides a convenient high level API suitable for most
- tasks and for the few cases where more control is needed it
- provides access to the full zlib feature set.
- </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/zlib/zlib-0.6.3.0.ebuild b/dev-haskell/zlib/zlib-0.6.3.0.ebuild
new file mode 100644
index 000000000000..ecdefa14223d
--- /dev/null
+++ b/dev-haskell/zlib/zlib-0.6.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.2.2.9999
+#hackport: flags: +pkg-config
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compression and decompression in the gzip and zlib formats"
+HOMEPAGE="https://hackage.haskell.org/package/zlib"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~ppc-macos"
+IUSE="bundled-c-zlib non-blocking-ffi"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ virtual/pkgconfig
+ test? ( >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ >=dev-haskell/tasty-0.8 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bundled-c-zlib bundled-c-zlib) \
+ $(cabal_flag non-blocking-ffi non-blocking-ffi) \
+ --flag=pkg-config
+}