summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-05-28 14:18:37 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-05-28 18:53:15 +0100
commitfeaf4692b297f9fc665e8b01c4be8d2981cb9458 (patch)
treebb754cda5179294b326194729e65de2c082978c0 /dev-haskell
parentdev-haskell/cereal-vector: new package, a depend of dev-haskell/stack (diff)
downloadgentoo-feaf4692b297f9fc665e8b01c4be8d2981cb9458.tar.gz
gentoo-feaf4692b297f9fc665e8b01c4be8d2981cb9458.tar.bz2
gentoo-feaf4692b297f9fc665e8b01c4be8d2981cb9458.zip
dev-haskell/store: new package, a depend of dev-haskell/stack
Fast binary serialization Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/store/Manifest1
-rw-r--r--dev-haskell/store/metadata.xml11
-rw-r--r--dev-haskell/store/store-0.3.1.ebuild67
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/store/Manifest b/dev-haskell/store/Manifest
new file mode 100644
index 000000000000..b9b17a2eedc1
--- /dev/null
+++ b/dev-haskell/store/Manifest
@@ -0,0 +1 @@
+DIST store-0.3.1.tar.gz 41555 SHA256 ec1005ebaf7334f6e5166315f8406553c94cffa8e06bc1d60f372c0d46ceda90 SHA512 7e6064cbee01ce7357e5b7235d502ee9b5b323358ebd7e71b5b310830ae52595384bb143dbbbad8e28cdde2c9001f1ae9ea03b47f2dc5cf50ac18cb2c4e9d7cd WHIRLPOOL b308ea6abf2a3a8cb44bffb62ddd59012af9ba943a4043560feaf6cd37ad6521893f2572211b0b137769f55020f144589fb8aeb36799b87b224225e9208bfb49
diff --git a/dev-haskell/store/metadata.xml b/dev-haskell/store/metadata.xml
new file mode 100644
index 000000000000..61d4d499fa23
--- /dev/null
+++ b/dev-haskell/store/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Fast binary serialization
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/store/store-0.3.1.ebuild b/dev-haskell/store/store-0.3.1.ebuild
new file mode 100644
index 000000000000..fd2828763476
--- /dev/null
+++ b/dev-haskell/store/store-0.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -small-bench,-comparison-bench
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast binary serialization"
+HOMEPAGE="https://github.com/fpco/store#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/async-2.0.2:=[profile?]
+ >=dev-haskell/base-orphans-0.4.3:=[profile?]
+ >=dev-haskell/base64-bytestring-0.1.1:=[profile?]
+ >=dev-haskell/conduit-1.2.3.1:=[profile?]
+ >=dev-haskell/contravariant-1.3:=[profile?]
+ >=dev-haskell/cryptohash-0.11.6:=[profile?]
+ >=dev-haskell/free-4.11:=[profile?]
+ >=dev-haskell/hashable-1.2.3.1:=[profile?]
+ >=dev-haskell/hspec-2.1.2:=[profile?]
+ >=dev-haskell/hspec-smallcheck-0.3.0:=[profile?]
+ >=dev-haskell/lifted-base-0.2.3.3:=[profile?]
+ >=dev-haskell/monad-control-0.3.3.0:=[profile?]
+ >=dev-haskell/mono-traversable-0.7.0:=[profile?]
+ >=dev-haskell/network-2.6.0.2:=[profile?]
+ >=dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/resourcet-1.1.3.3:=[profile?]
+ >=dev-haskell/safe-0.3.8:=[profile?]
+ >=dev-haskell/semigroups-0.8:=[profile?]
+ >=dev-haskell/smallcheck-1.1.1:=[profile?]
+ >=dev-haskell/store-core-0.3:=[profile?] <dev-haskell/store-core-0.4:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.10.0:=[profile?]
+ >=dev-haskell/syb-0.4.4:=[profile?]
+ >=dev-haskell/text-1.2.0.4:=[profile?]
+ >=dev-haskell/th-lift-0.7.1:=[profile?]
+ >=dev-haskell/th-lift-instances-0.1.4:=[profile?]
+ >=dev-haskell/th-orphans-0.12.2:=[profile?]
+ >=dev-haskell/th-reify-many-0.1.6:=[profile?]
+ >=dev-haskell/th-utilities-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5.1:=[profile?]
+ >=dev-haskell/vector-0.10.12.3:=[profile?]
+ >=dev-haskell/void-0.5.11:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/cereal
+ dev-haskell/cereal-vector
+ dev-haskell/criterion
+ dev-haskell/vector-binary-instances
+ dev-haskell/weigh )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-comparison-bench \
+ --flag=-small-bench
+}