summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild')
-rw-r--r--dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild b/dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild
new file mode 100644
index 000000000000..1604cd90ba45
--- /dev/null
+++ b/dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A collection of tasks (and at one point maybe types and other tools) for Apache Ant"
+HOMEPAGE="http://ant-contrib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ant-contrib/${PN}-${PV/_beta/b}-src.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+# test? ( dev-java/ant-junit dev-java/ant-testutil )
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/bcel-5.1
+ >=dev-java/xerces-2.7
+ >=dev-java/ant-core-1.7.0"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/tests-visibility.patch"
+ cd "${S}/lib"
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from bcel bcel.jar bcel-5.1.jar
+ java-pkg_jar-from xerces-2
+}
+
+EANT_EXTRA_ARGS="-Dversion=${PV} -Ddep.available=true"
+EANT_DOC_TARGET="docs"
+
+# The tests fail to find bcel and fail
+RESTRICT="test"
+
+src_test() {
+ cd test/lib || die
+ java-pkg_jar-from junit junit.jar junit-3.8.1.jar
+ java-pkg_jar-from ant-testutil
+ cd "${S}"
+ local testutil=$(java-pkg_getjars ant-testutil)
+ EANT_TEST_EXTRA_ARGS="-Dtestutil.jar.location=${testutil}" \
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar build/lib/${PN}.jar
+
+ java-pkg_register-ant-task
+ dodoc README.txt || die
+ use doc && java-pkg_dojavadoc build/docs/api
+ use source && java-pkg_dosrc src/net
+ java-pkg_dohtml -r manual
+}