summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ant
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ant')
-rw-r--r--dev-java/ant/ant-1.9.2.ebuild64
-rw-r--r--dev-java/ant/metadata.xml21
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-java/ant/ant-1.9.2.ebuild b/dev-java/ant/ant-1.9.2.ebuild
new file mode 100644
index 000000000000..7ad645263e2a
--- /dev/null
+++ b/dev-java/ant/ant-1.9.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit versionator
+
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files"
+HOMEPAGE="http://ant.apache.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="~dev-java/ant-core-${PV}"
+RDEPEND="${DEPEND}"
+
+IUSE="X +antlr +bcel +bsf +commonslogging +commonsnet jai +javamail +jdepend jmf
+ +jsch +log4j +oro +regexp +resolver testutil"
+
+RDEPEND="~dev-java/ant-core-${PV}
+ ~dev-java/ant-nodeps-${PV}
+ ~dev-java/ant-junit-${PV}
+ !dev-java/ant-optional
+ !dev-java/ant-tasks
+ ~dev-java/ant-trax-${PV}
+ ~dev-java/ant-apache-xalan2-${PV}
+ antlr? ( ~dev-java/ant-antlr-${PV} )
+ bcel? ( ~dev-java/ant-apache-bcel-${PV} )
+ bsf? ( ~dev-java/ant-apache-bsf-${PV} )
+ log4j? ( ~dev-java/ant-apache-log4j-${PV} )
+ oro? ( ~dev-java/ant-apache-oro-${PV} )
+ regexp? ( ~dev-java/ant-apache-regexp-${PV} )
+ resolver? ( ~dev-java/ant-apache-resolver-${PV} )
+ commonslogging? ( ~dev-java/ant-commons-logging-${PV} )
+ commonsnet? ( ~dev-java/ant-commons-net-${PV} )
+ jai? ( ~dev-java/ant-jai-${PV} )
+ javamail? ( ~dev-java/ant-javamail-${PV} )
+ jdepend? ( ~dev-java/ant-jdepend-${PV} )
+ jmf? ( ~dev-java/ant-jmf-${PV} )
+ jsch? ( ~dev-java/ant-jsch-${PV} )
+ testutil? ( ~dev-java/ant-testutil-${PV} )
+ X? ( ~dev-java/ant-swing-${PV} )"
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_compile() { :; }
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ # if we update from a version below 1.7.1
+ if ! version_is_at_least 1.7.1 ${REPLACING_VERSIONS}; then
+ elog "Since 1.7.1, the ant-tasks meta-ebuild has been removed and its USE"
+ elog "flags have been moved to dev-java/ant."
+ elog
+ elog "You may now freely set the USE flags of this package without breaking"
+ elog "building of Java packages, which depend on the exact ant tasks they need."
+ elog "The USE flags default to enabled (except X, jai and jmf) for convenience."
+ fi
+ fi
+}
diff --git a/dev-java/ant/metadata.xml b/dev-java/ant/metadata.xml
new file mode 100644
index 000000000000..6cfffe619d55
--- /dev/null
+++ b/dev-java/ant/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <use>
+ <flag name="antlr">Enable ANTLR Ant tasks</flag>
+ <flag name="bcel">Enable bcel (bytecode manipulation) Ant tasks</flag>
+ <flag name="commonslogging">Enable commons-logging Ant tasks</flag>
+ <flag name="commonsnet">Enable commons-net Ant tasks</flag>
+ <flag name="jai">Enable JAI (Java Imaging) Ant task</flag>
+ <flag name="javamail">Enable JavaMail Ant task</flag>
+ <flag name="jdepend">Enable Jdepend Ant tasks</flag>
+ <flag name="jmf">Enable JMF (Java Media Framework) Ant tasks</flag>
+ <flag name="jsch">Disable Jsch (ssh, scp and related) Ant tasks</flag>
+ <flag name="log4j">Enable Apache log4j Ant tasks</flag>
+ <flag name="oro">Enable Apache Oro Ant tasks</flag>
+ <flag name="regexp">Enable Apache Regexp Ant tasks</flag>
+ <flag name="resolver">Enable Apache Resolver Ant tasks</flag>
+ <flag name="testutil">Enable optional test util classes</flag>
+ </use>
+</pkgmetadata>