summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/asm/asm-5.0.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/asm/asm-5.0.3.ebuild')
-rw-r--r--dev-java/asm/asm-5.0.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/asm/asm-5.0.3.ebuild b/dev-java/asm/asm-5.0.3.ebuild
new file mode 100644
index 000000000000..d006b9f27836
--- /dev/null
+++ b/dev-java/asm/asm-5.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OLD_P="${PN}-4.0"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Bytecode manipulation framework for Java"
+HOMEPAGE="http://asm.ow2.org"
+SRC_URI="http://download.forge.objectweb.org/${PN}/${P}.tar.gz
+ http://download.forge.objectweb.org/${PN}/${OLD_P}.tar.gz"
+LICENSE="BSD"
+SLOT="4"
+IUSE=""
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-fbsd ~x64-macos"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+# Needs dependencies we don't have yet.
+RESTRICT="test"
+
+EANT_DOC_TARGET="jdoc"
+
+# Fails if this objectweb.ant.tasks.path is not set.
+# Java generics seem to break unless product.noshrink is set.
+EANT_EXTRA_ARGS="-Dobjectweb.ant.tasks.path=foobar -Dproduct.noshrink=true"
+
+java_prepare() {
+ # Borrow some ant scripts from an old version to avoid requiring
+ # bndlib and friends. This may not work forever!
+ cp -vf "../${OLD_P}/archive"/*.xml archive/ || die
+}
+
+src_install() {
+ for x in output/dist/lib/*.jar ; do
+ java-pkg_newjar "${x}" $(basename "${x%-*}.jar")
+ done
+
+ use doc && java-pkg_dojavadoc output/dist/doc/javadoc/user/
+ use source && java-pkg_dosrc src/*
+}